Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41913 - [ardour] harvid is needed to import videos

Attached to Project: Arch Linux
Opened by David Runge (dvzrv) - Wednesday, 10 September 2014, 15:23 GMT
Last edited by Ray Rashif (schivmeister) - Monday, 03 November 2014, 12:00 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Ray Rashif (schivmeister)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Title says it all: Without harvid installed, you can't really import videos in Ardour (Ardour will actually try to start harvid on its own, but of course won't be able to find it).
This being said, it should be included in the Optional Deps alongside xjadeo.

Additional info:
ardour-3.5.380-1
xjadeo-0.8.0-1

Steps to reproduce:
Install Ardour and its Optional Deps.
Open Ardour.
Click "Session -> Open Video".
This task depends upon

Closed by  Ray Rashif (schivmeister)
Monday, 03 November 2014, 12:00 GMT
Reason for closing:  Implemented
Additional comments about closing:  Updated in trunk; change will show up on next upstream update.
Comment by Ray Rashif (schivmeister) - Monday, 15 September 2014, 06:19 GMT
  • Field changed: Task Type (Bug Report → Feature Request)
This is not a bug, but an optional feature. I chose to not bring harvid into the repos as it was (and still is) beta and had its own ffmpeg. Take a look at the install scriptlet for ardour:

$ pacscripts ardour
post_install() {
....
> Ardour 3 also supports video (timeline and monitoring), but aside from
> xjadeo the required external programs need to be retrieved from:

http://x42.github.io/harvid/
...

It is true however that this method of fulfilling dependencies partially from the repos and then from outside sources is cumbersome. I will revisit harvid now and see if it's been stable enough.
Comment by David Runge (dvzrv) - Monday, 15 September 2014, 12:03 GMT
Ah sorry, should've set the Task Type correctly...
Yes, it's a feature request, of course!
I was stumbling upon it, working with Ardour lately and then seeing that harvid is now in community (like xjadeo).
I tested/used them in conjunction and it seemed to work fine, when importing videos.

Thanks for taking a look!
Comment by Ray Rashif (schivmeister) - Monday, 15 September 2014, 15:23 GMT
Thanks for bringing this up, it seems harvid has not shown any trouble while in [community], so I will just include it as an optdep like requested.

Loading...