Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#4188 - kernel26archck's initramfs needs to use run-init from klibc

Attached to Project: Arch Linux
Opened by Ben Webber (bengi) - Saturday, 18 March 2006, 01:28 GMT
Last edited by Tobias Powalowski (tpowa) - Friday, 31 March 2006, 17:10 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To James Rayner (iphitus)
Architecture not specified
Severity High
Priority Normal
Reported Version 0.7.1 Noodle
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have a problem with kernel26archck and mkinitramfs. I am using linux software raid and have the raid devices /dev/md0 - /dev/md4. The problem is that only the md device node that is configured in initramfs.conf by RAID_ROOT_ARRAY is created in the initramfs image. This means that mdadm is unable to start the other 4 arrays. In rc.sysinit on line 64 rc.sysinit checks to see if /initrd/dev exists and if it does then tries to copy /initrd/dev/md? to /dev. I think that the reason that the device nodes are not created is that /initrd/dev doesn't exist when rc.sysinit executes and rc.sysinit is therefore unable to copy the device nodes from the initramfs image. As kernel2karchck uses initramfs instead of initrd it cannot pivot_root like initrd because pivot_root does not work with initramfs. In initrd when pivot_root is executed pivot_root remounts / as new_root/initrd. If there is no command in the init script of the initramfs image to remount or copy the contents of the initramfs image to /initrd some how and clean up the initramfs image then once chrooted from the initramfs image to my root filesystem /initrd/dev doesn't exist and rc.sysinit can't copy of the device nodes. I have found a link to a LUG here which talks about using run-init from the klibc package as a replacement for pivot_root in initramfs. Here is the link:-

http://www.thisishull.net/showthread.php?t=65762

I think klibc needs to be added to the initramfs image and mkinitramfs needs to include a line which adds run-init to the init script in the initramfs image.

For reference here is a link to my post on the forums regarding this:-

http://bbs.archlinux.org/viewtopic.php?t=17332&postdays=0&postorder=asc&start=30


Ben
This task depends upon

Closed by  James Rayner (iphitus)
Sunday, 16 April 2006, 00:27 GMT
Reason for closing:  Fixed
Comment by James Rayner (iphitus) - Tuesday, 04 April 2006, 11:09 GMT
Give the latst mkinitramfs a shot and let me know how you go. I havn't used klibc but it ought to work.
Comment by James Rayner (iphitus) - Sunday, 09 April 2006, 10:03 GMT
http://bbs.archlinux.org/viewtopic.php?t=20367

Will close, assumed fixed in a week if there are no issues raised.
Comment by James Rayner (iphitus) - Sunday, 16 April 2006, 00:27 GMT
It's been a week since that last message, and this bug has been open for nearly a month with no comment.

There have been no complaints raised with the current version, and no negative replies to any requests for testing, so I assume my fixes have worked.

Closing bug as fixed.

Loading...