Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41831 - [mupdf] Use systems openjpeg2 package to avoid SIGSEGVs if libmupdf.a is used

Attached to Project: Community Packages
Opened by Moritz Lipp (mlq) - Friday, 05 September 2014, 08:02 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Sunday, 07 September 2014, 07:09 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

A lot of users complain that the zathura-pdf-mupdf plugin makes them crash zathura if they view images with huge JPGs. I could confirm that behaviour and found out that the SIGSEGV happened in:

#0 0x00007fffd5006010 in ?? ()
#1 0x00007fffe8ac8d67 in opj_stream_destroy () from /usr/lib/libopenjp2.so.7

What we see is that it is linked to systems libopenjpg2, but mupdf is built against the one in the thirdparty directory - so those two don't match. On the other hand there must be something wrong with the
build, because you explicitely need to relink against openjpg2, because otherwise it does not find the symbol obj_setup_decoder and in the end that doesn't work out very well anymore.

As a solution I've written a small patch that makes the package use openjpeg2 provided by archlinux; so it does not depend anymore on any thirdparty sources provided by mupdf.

Additional info:

* mupdf 1.5
* zathura 0.2.9
* zathura-pdf-mupdf 0.2.6

Steps to reproduce:

* Install the above packages
* Download http://bugs.pwmt.org/file195/guide_book.pdf
* Try to open the PDF: zathura guide_book.pdf
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Sunday, 07 September 2014, 07:09 GMT
Reason for closing:  Fixed
Additional comments about closing:  mupdf 1.5-2
zathura-pdf-mupdf 0.2.6-5

Loading...