Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.

FS#4182 - Total Download Size

Attached to Project: Pacman
Opened by Roman Kyrylych (Romashka) - Friday, 17 March 2006, 13:08 GMT
Last edited by Roman Kyrylych (Romashka) - Sunday, 21 October 2007, 15:40 GMT
Task Type Feature Request
Status Closed
Assigned To Roman Kyrylych (Romashka)
Architecture not specified
Severity Medium
Priority Normal
Reported Version 0.7.1 Noodle
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Currently Pacman shows Total Package Size which is the size of all packages that are going to be installed including those that are in /var/cache/pacman/pkg/.
I propose to add Total Download Size that will show the size of packages that are going to be downloaded (those that are not in /var/cache/pacman/pkg/).
This task depends upon

This task blocks these from closing
 FS#8109 - Pacman 3.1 Release Roadmap 
Closed by  Roman Kyrylych (Romashka)
Sunday, 21 October 2007, 15:40 GMT
Reason for closing:  Implemented
Additional comments about closing:  in git
Comment by dtw (dibblethewrecker) - Wednesday, 16 August 2006, 13:54 GMT
I agree. When you consider that the size of the pkgs refers purely to the compressed pkg size then the total size information is really _only_ relevant in terms of download size/time. Therefore total size is actually largely irrelevant and could be completely replaced by download size.
Comment by Roman Kyrylych (Romashka) - Wednesday, 16 August 2006, 14:22 GMT
Well, you are right. It really can be only download size, as total size doesn't really matter.
Comment by Roman Kyrylych (Romashka) - Tuesday, 05 December 2006, 09:53 GMT
Pacman 3 displays both "Total
Package Size" and "Total Installed Size" assuming the repo is
generated with the new tools to include uncompressed size.

But the request was about Total *Download* Size. Which is the size of compressed files, that are going to be _downloaded_, which doesn't include packages already in cache.
Comment by Roman Kyrylych (Romashka) - Wednesday, 03 January 2007, 22:54 GMT
BTW, in the latest pacman-rc-3.0.0-3 I can see only Total Download Size, no Total Install Size.
Comment by Roman Kyrylych (Romashka) - Wednesday, 03 January 2007, 22:55 GMT
oops, sed s/Download/Package/ of course
Comment by Aaron Griffin (phrakture) - Wednesday, 03 January 2007, 22:57 GMT
That's because it needs additional information in the repo. You can make a custom repo using repo-add in order to test if you want.
Comment by Dan McGee (toofishes) - Tuesday, 30 January 2007, 07:54 GMT
Repos will have to be rebuilt in order to include this data, but the functionality is there in pacman to display it if available. Closing because it is fixed as a feature request.

The repo-add script is currently the only way to add this data- future tools should incorporate it as well.
Comment by Roman Kyrylych (Romashka) - Tuesday, 30 January 2007, 09:16 GMT
Sorry, Dan. But this feature request is not fixed.
Pacman does not show the size of packages that will be _downloaded_, which is = totalsize - cachedsize.
User has no idea how much of Total Package Size is already on his/her HDD.
Comment by Aaron Griffin (phrakture) - Monday, 12 February 2007, 00:20 GMT
Deferring for 3.1 release