Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41683 - [linux] render ring initialization fails with some intergreated video devices (patch included)

Attached to Project: Arch Linux
Opened by John (graysky) - Sunday, 24 August 2014, 21:54 GMT
Last edited by Jan de Groot (JGC) - Monday, 12 January 2015, 11:28 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Some Intel interrogated video hardware is rendered useless by a recent kernel bug. On my system, useless means X is a black screen on my Intel GMA X4500HD. Others have reported this bug with newer hardware as well.[1] Upstream has a patch which was submitted to the stable team on Aug 7th, but I find no traces of it in the stable queue.[2] The developer himself mentioned on Aug 7th, that it will get backported to stable kernels eventually, I think we should consider it important enough to add to our kernel until it is accepted.[3]

The error is reported in dmesg:

[drm:init_ring_common] *ERROR* render ring initialization failed ctl 0001f001 (valid? 1) head 00000298 tail 00000000 start 001d8000 [expected 001d8000]
[drm:i915_gem_init] *ERROR* Failed to initialize GPU, declaring it wedged

Upstream report: https://bugs.freedesktop.org/show_bug.cgi?id=76554
Upstream patch: https://bugs.freedesktop.org/attachment.cgi?id=104224

1. https://bbs.archlinux.org/viewtopic.php?id=185650
2. https://git.kernel.org/cgit/linux/kernel/git/stable/stable-queue.git/tree/queue-3.16
3. https://bugs.freedesktop.org/show_bug.cgi?id=76554#c103

Additional info:
* package version(s) 3.16.1-1
* config and/or log files etc.

Steps to reproduce:
1. Run the affected hardware and boot the machine.
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 12 January 2015, 11:28 GMT
Reason for closing:  Fixed
Comment by John (graysky) - Thursday, 02 October 2014, 14:00 GMT
  • Field changed: Percent Complete (100% → 0%)
This bug is not the same as  FS#41573  or  FS#41045  but is related. This patch does indeed fix the wedged status of intel hardware as I reported. Please reopen and consider adding it since 3.16.2 does not yet have this patch.
Comment by John (graysky) - Thursday, 02 October 2014, 14:24 GMT
Actually you guys can probably close this since the upstream patch should be part of 3.16.4-rc1 whenever Greg packages it.[1]

1. https://git.kernel.org/cgit/linux/kernel/git/stable/stable-queue.git/tree/queue-3.16/drm-i915-read-head-register-back-in-init_ring_common-to-enforce-ordering.patch
Comment by John (graysky) - Saturday, 29 November 2014, 02:04 GMT
Yeah, this has been long merged. Safe to close in my opinion.

Loading...