Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41671 - grub-mkconfig believes that linux-lts is a newer kernel version than linux

Attached to Project: Arch Linux
Opened by Andreas Källberg (Hjulle) - Sunday, 24 August 2014, 00:32 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 24 August 2014, 03:40 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When using grub-mkconfig to generate a grub configuration the script /etc/grub.d/10_linux will automatically try to detect the newest kernel version available and use it as the default. It uses "sort -V" on the kernel names to find the newest kernel version. Since adding a suffix to the version number/name counts as a newer version, this holds for "vmlinuz-linux" and "vmlinuz-linux-lts" too.

I installed both linux and linux-lts to have the latter as a fall-back. This bug forces me to use a manual configuration (eg. 40_custom) if I want to use the latest kernel as default.

Additional info:
Package version(s):
* linux 3.16.1-1
* linux-lts 3.14.17-1
* grub 1:2.02.beta2-4

* config and/or log files etc.

Steps to reproduce:
1. Install grub, linux and linux-lts
2. Run grub-mkconfig
3. Confirm that it selects linux-lts as the default kernel
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 24 August 2014, 03:40 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#28081

Loading...