Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#4167 - avahi-daemon fails to start

Attached to Project: Arch Linux
Opened by Arthur Danskin (wiremore) - Tuesday, 14 March 2006, 06:46 GMT
Last edited by arjan timmerman (blaasvis) - Thursday, 16 March 2006, 16:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To James Rayner (iphitus)
Architecture not specified
Severity Medium
Priority Normal
Reported Version 0.7.1 Noodle
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


when I try and start avahi-daemon from the rc scripts, it fails. I also tried starting the daemon directly:

~>sudo avahi-daemon
cap_set_proc() failed: Operation not permitted

This is what I get. This is on a fully updated (testing) system with archck kernel.
This task depends upon

Closed by  arjan timmerman (blaasvis)
Thursday, 23 March 2006, 08:03 GMT
Reason for closing:  Not a bug
Comment by Arthur Danskin (wiremore) - Tuesday, 14 March 2006, 06:55 GMT
This can be fixed with a simple:

sudo modprobe capability
Comment by arjan timmerman (blaasvis) - Thursday, 16 March 2006, 12:41 GMT
maybe this should be fixed in archck ;)
Comment by Jan de Groot (JGC) - Thursday, 16 March 2006, 13:38 GMT
kernel26 will get the same "feature" ;)
Comment by James Rayner (iphitus) - Thursday, 16 March 2006, 23:47 GMT
aint going to be 'fixed' in archck, as capability needs to be a module for realtime-lsm.

In the meantime, add capability to your MODULES=() line.

And yeah, kernel26 will be getting the same feature too