Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41638 - [bluez-utils] add gatttool to the package

Attached to Project: Arch Linux
Opened by Steven Honeyman (stevenhoneyman) - Wednesday, 20 August 2014, 22:00 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 22 August 2014, 17:02 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

It's already part of the source, and it is a "bluez-util" so belongs in this package really. It's used for testing/configuring/reading data from BT4 LE devices like heart rate monitors etc.

Steps to fix:

Ref - https://aur.archlinux.org/packages/ga/gatttool/PKGBUILD
It should be a one-liner:

install -vDm755 attrib/gatttool "${pkgdir}/usr/bin/gatttool"
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 22 August 2014, 17:02 GMT
Reason for closing:  Implemented
Additional comments about closing:  5.22-2
Comment by Steven Honeyman (stevenhoneyman) - Friday, 22 August 2014, 17:01 GMT
  • Field changed: Percent Complete (100% → 0%)
The "duplicate" should never have been closed. "AndyRTR" didn't bother to read the git commit he linked to - the *plugin* is no longer required, but (quoted): "Note that GATT utility (gatttool) configuration item was moved to Makefile.tools". Please re-open as this is still a valid, maintained, and required program.

Loading...