Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41573 - [linux] intel-dri crashes on startup?

Attached to Project: Arch Linux
Opened by Matthias Krüger (matthiaskrgr) - Saturday, 16 August 2014, 10:28 GMT
Last edited by Laurent Carlier (lordheavy) - Monday, 08 September 2014, 12:20 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan de Groot (JGC)
Thomas Bächler (brain0)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

I'm not sure if this is related to this package or kernel.
Since around yesterday, 3d-support on my t400 is broken.
Everything that needs OpenGL runs veeeeeery slow.

dmesg lists this:
>[ 15.821109] [drm:init_ring_common] *ERROR* render ring initialization failed ctl 0001f001 (valid? 1) head 0000c020 tail 00000000 start 00042000 [expected 00042000]
>[ 15.821126] [drm:i915_gem_init] *ERROR* Failed to initialize GPU, declaring it wedged


[ 15.489415] [drm] Initialized drm 1.1.0 20060810
[ 15.659932] thermal LNXTHERM:00: registered as thermal_zone0
[ 15.659936] ACPI: Thermal Zone [THM0] (66 C)
[ 15.661439] thermal LNXTHERM:01: registered as thermal_zone1
[ 15.661442] ACPI: Thermal Zone [THM1] (63 C)
[ 15.665680] e1000e 0000:00:19.0 eth0: (PCI Express:2.5GT/s:Width x1) 00:1c:25:97:11:1f
[ 15.665683] e1000e 0000:00:19.0 eth0: Intel(R) PRO/1000 Network Connection
[ 15.665707] e1000e 0000:00:19.0 eth0: MAC: 7, PHY: 8, PBA No: 1008FF-0FF
[ 15.666311] pci 0000:00:00.0: Intel GM45 Chipset
[ 15.666331] pci 0000:00:00.0: detected gtt size: 2097152K total, 262144K mappable
[ 15.667692] pci 0000:00:00.0: detected 32768K stolen memory
[ 15.667724] [drm] Memory usable by graphics device = 2048M
[ 15.667726] [drm] Replacing VGA console driver
[ 15.668224] Console: switching to colour dummy device 80x25
[ 15.686750] i915 0000:00:02.0: irq 45 for MSI/MSI-X
[ 15.686763] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[ 15.686765] [drm] Driver supports precise vblank timestamp query.
[ 15.686841] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem
[ 15.688141] wmi: Mapper loaded
[ 15.736326] Non-volatile memory driver v1.3
[ 15.821109] [drm:init_ring_common] *ERROR* render ring initialization failed ctl 0001f001 (valid? 1) head 0000c020 tail 00000000 start 00042000 [expected 00042000]
[ 15.821126] [drm:i915_gem_init] *ERROR* Failed to initialize GPU, declaring it wedged
[ 15.821240] thinkpad_acpi: ThinkPad ACPI Extras v0.25
[ 15.821241] thinkpad_acpi: http://ibm-acpi.sf.net/
[ 15.821243] thinkpad_acpi: ThinkPad BIOS 7UET46WW (1.16 ), EC 7VHT12WW-1.01
[ 15.821244] thinkpad_acpi: Lenovo ThinkPad T400, model 2767A26
[ 15.842832] thinkpad_acpi: detected a 16-level brightness capable ThinkPad
[ 15.842998] thinkpad_acpi: radio switch found; radios are enabled
[ 15.843088] thinkpad_acpi: This ThinkPad has standard ACPI backlight brightness control, supported by the ACPI video driver
[ 15.843090] thinkpad_acpi: Disabling thinkpad-acpi brightness events by default...
[ 15.845351] fbcon: inteldrmfb (fb0) is primary device
[ 15.848628] thinkpad_acpi: Standard ACPI backlight interface available, not loading native one
[ 15.848698] thinkpad_acpi: Console audio control enabled, mode: monitor (read only)
[ 15.849654] input: ThinkPad Extra Buttons as /devices/platform/thinkpad_acpi/input/input5
[ 16.336852] Console: switching to colour frame buffer device 180x56



Additional info:

linux 3.16.1-1
intel-dri 10.2.5-1
mesa 10.2.5-1

attached: dmesg.log


Steps to reproduce:
boot system and start OGL programms
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Monday, 08 September 2014, 12:20 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#41045 
Comment by Anton Tsyganenko (anton-tsyganenko) - Saturday, 16 August 2014, 19:37 GMT
Looks similar to https://bugs.archlinux.org/task/41045, but there openGL-apps just crash.
Comment by Matthias Krüger (matthiaskrgr) - Saturday, 16 August 2014, 19:39 GMT
Yeah, I'm also the reporter of that one ;)
That bug needs a suspend to ram to crash OGL apps, this ticket is about OGL running EXTREMELY slow (6 fps where I'd get 20-40 usually), even without suspend.
Comment by Anton Tsyganenko (anton-tsyganenko) - Sunday, 17 August 2014, 10:51 GMT
that bug doesn't need a suspend anymore.
Comment by Matthias Krüger (matthiaskrgr) - Sunday, 17 August 2014, 11:45 GMT
Hmm.. well, if you want you can close that ticket then.
Comment by Anton Tsyganenko (anton-tsyganenko) - Sunday, 17 August 2014, 12:15 GMT
I think, it's the same bug, but you have acceleration disabled. After I disabled acceleration, openGL-apps started running slowly instead of crashing.
Comment by Matthias Krüger (matthiaskrgr) - Sunday, 17 August 2014, 12:20 GMT
Hmm I can't remember changing anything (config files) before the slowdown occurred.
Comment by Anton Tsyganenko (anton-tsyganenko) - Sunday, 17 August 2014, 12:32 GMT
Could you post content of /etc/X11/xorg.conf.d/20-intel.conf, if it exists.
Comment by Matthias Krüger (matthiaskrgr) - Sunday, 17 August 2014, 12:36 GMT
Section "Device"
Identifier "Intel Graphics"
Driver "intel"
# disable the chip. remove both if drivers are fixed, should be next release
# Option "NoAccel" "True"
# Option "DRI" "False"

# I should be able to remove this with xorg > 1.15.0
# Option "AccelMethod" "blt"

# try fixing black firefox and stuff:
Option "AccelMethod" "uxa"

EndSection


(currently I re-enabled the dedicated card which sucks more power but doesn't crash and is faster)
Comment by Anton Tsyganenko (anton-tsyganenko) - Sunday, 17 August 2014, 12:41 GMT
I think, it's because of uxa.
Comment by Matthias Krüger (matthiaskrgr) - Sunday, 17 August 2014, 12:47 GMT
Hmm indeed, whenm I comment it out, it works fine as before. Thank you!

Edit: So it can be closed as invalid.
Comment by Anton Tsyganenko (anton-tsyganenko) - Sunday, 17 August 2014, 13:04 GMT
What did you commented out?
Comment by Matthias Krüger (matthiaskrgr) - Sunday, 17 August 2014, 13:08 GMT
Option "AccelMethod" "uxa"
Comment by Oscar Morante (spacepluk) - Wednesday, 20 August 2014, 05:19 GMT
I was getting the same error with SNA. I patched the kernel with this and it's working fine so far:

https://bugs.freedesktop.org/attachment.cgi?id=104224

The whole discussion here: https://bugs.freedesktop.org/show_bug.cgi?id=76554
Comment by John (graysky) - Monday, 25 August 2014, 07:05 GMT
Since we seem to have several active (?) tickets open on this topic, I will post the info I did to  FS#41045  to this one too. Sorry if this is poor etiquette:

Some Intel interrogated video hardware is rendered useless by this recent kernel bug. On my system, useless means X is a black screen on my Intel GMA X4500HD. Others have reported this bug with newer hardware as well.[1] Upstream has a patch which was submitted to the stable team on Aug 7th, but I find no traces of it in the stable queue.[2] The developer himself mentioned on Aug 7th, that it will get backported to stable kernels eventually, I think we should consider it important enough to add to our kernel until it is accepted.[3]

Upstream report: https://bugs.freedesktop.org/show_bug.cgi?id=76554
Upstream patch: https://bugs.freedesktop.org/attachment.cgi?id=104224

1. https://bbs.archlinux.org/viewtopic.php?id=185650
2. https://git.kernel.org/cgit/linux/kernel/git/stable/stable-queue.git/tree/queue-3.16
3. https://bugs.freedesktop.org/show_bug.cgi?id=76554#c103

Additional info:
* package version(s) 3.16.1-1
* the error is reported in dmesg:

[drm:init_ring_common] *ERROR* render ring initialization failed ctl 0001f001 (valid? 1) head 00000298 tail 00000000 start 001d8000 [expected 001d8000]
[drm:i915_gem_init] *ERROR* Failed to initialize GPU, declaring it wedged

Steps to reproduce:
1. Run the affected hardware and boot the machine.

Loading...