Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41493 - [tar] lzip: Cannot exec -- (lzip missing from repos)

Attached to Project: Arch Linux
Opened by Steven Honeyman (stevenhoneyman) - Wednesday, 06 August 2014, 18:54 GMT
Last edited by Sébastien Luttringer (seblu) - Thursday, 21 August 2014, 15:04 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To Sébastien Luttringer (seblu)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

tar has support for lzip, but only works if the lzip program is installed. unfortunately it isn't in the Arch repos.
this also affects the "mtools" package which contains 'lz' and 'uz' that both need lzip binary.

http://download.savannah.gnu.org/releases/lzip/

Steps to reproduce:

$ tar xvf moe-1.6.tar.lz
tar (child): lzip: Cannot exec: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
$ pkgfile /usr/bin/lzip
$
This task depends upon

Closed by  Sébastien Luttringer (seblu)
Thursday, 21 August 2014, 15:04 GMT
Reason for closing:  Won't implement
Additional comments about closing:  lzip is not a dep of tar. Find someone to add this package in official repositories.
Comment by Dave Reisner (falconindy) - Wednesday, 06 August 2014, 19:03 GMT
Who uses this? Does bsdtar work (it has native support for lzma).
Comment by Steven Honeyman (stevenhoneyman) - Wednesday, 06 August 2014, 19:10 GMT
http://www.gnu.org/software/moe/

the first and only thing I've ever seen that does use this strange format, but yes, thank-you - bsdtar extracted it fine.
(I tried and failed with 7z, xz, and lz4. "lz" from mtools package just calls lzip...!)

maybe then (as nobody uses lzip) this could be re-assigned to mtools (as a bug) because 2 of the programs that provides just crash without lzip
Comment by Sébastien Luttringer (seblu) - Friday, 08 August 2014, 00:08 GMT
lzip option cannot be disabled. './configure --without-lzip' set the lzip path to 'no'.

lz and uz are shell wrappers which may call gzip, bzip2 and lzip based on file extension. Not really different than tar.

Loading...