Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41474 - Unable to boot Linux 3..16.0-2 on ASUS K53TA laptop

Attached to Project: Arch Linux
Opened by Sandeep (sandy8925) - Tuesday, 05 August 2014, 07:53 GMT
Last edited by Tobias Powalowski (tpowa) - Sunday, 10 August 2014, 16:53 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After initramfs boot, screen freezes, and white noise begins filling the screen, gradually making the entire screen bright. Kernel is non-responsive to Ctrl+Alt+Del and SysRq combination (Ctrl + Alt + PrtSc + R,S,E,I,S,U,B).

Problem is present on Linux 3.16.0-2 and NOT present on Linux 3.16.0-1
Occurs for both normal and fallback initramfs
Problem appears to be in radeon kernel module
Using kernel parameters radeon.runpm=0 and radeon.audio=0 on kernel line in bootloader, solves the issue, allowing the kernel to boot.

Additional info:
* Have radeon.runpm=0 and radeon.audio=1 set in modprobe.d directory
* acpi_sleep=s3_bios is also used as kernel parameter (does not seem to cause the problem though)


Steps to reproduce:
Boot Linux 3.16.0-2 kernel normally
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Sunday, 10 August 2014, 16:53 GMT
Reason for closing:  Not a bug
Comment by Sandeep (sandy8925) - Tuesday, 05 August 2014, 08:04 GMT
Strangely enough, it's working fine now, with the same configuration as before.

May have just been an overheating issue or temporary glitch. Will monitor and report back.
Comment by Doug Newgard (Scimmia) - Friday, 08 August 2014, 13:58 GMT
It's been a few days, anything new on this?
Comment by Lukas Fleischer (lfleischer) - Sunday, 10 August 2014, 08:20 GMT
3.16-1 and 3.16-2 only differ in the default log level. It is very unlikely that the issue described above is related to the kernel update. Since the reporter himself said it is working fine now, I would just close this.

Loading...