Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41406 - [samba][ldb] conflicting files

Attached to Project: Arch Linux
Opened by Christian Hesse (eworm) - Thursday, 31 July 2014, 07:49 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 31 July 2014, 09:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:
samba 4.1.10-1 and ldb 1.1.16-1 packages have conflicting files:

/usr/bin/ldbadd exists in filesystem
/usr/bin/ldbdel exists in filesystem
/usr/bin/ldbedit exists in filesystem
/usr/bin/ldbmodify exists in filesystem
/usr/bin/ldbrename exists in filesystem
/usr/bin/ldbsearch exists in filesystem
/usr/lib/python2.7/site-packages/ldb.so exists in filesystem
/usr/share/man/man1/ldbadd.1.gz exists in filesystem
/usr/share/man/man1/ldbdel.1.gz exists in filesystem
/usr/share/man/man1/ldbedit.1.gz exists in filesystem
/usr/share/man/man1/ldbmodify.1.gz exists in filesystem
/usr/share/man/man1/ldbrename.1.gz exists in filesystem
/usr/share/man/man1/ldbsearch.1.gz exists in filesystem
/usr/share/man/man3/ldb.3.gz exists in filesystem

Additional info:
samba 4.1.10-1
ldb 1.1.16-1
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Thursday, 31 July 2014, 09:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  4.1.10-2
Comment by Christian Hesse (eworm) - Thursday, 31 July 2014, 08:11 GMT
Perhaps you should add --bundled-libraries=NONE to configure options to prevent this.
Comment by Oliver Matthews (cwoac) - Thursday, 31 July 2014, 08:44 GMT
Seeing this as well. It appears to be a re-occurrence of  FS#36022 
Comment by Christian Hesse (eworm) - Thursday, 31 July 2014, 08:48 GMT
Adding --bundled-libraries=NONE may ba a bit problematic as samba comes with a lot of bundled libraries that are actually required. Something like --bundled-libraries=!tdb,!talloc,!pytalloc-util,!tevent,!popt,!ldb,!pyldb-util may be worth it.
Comment by Tobias Powalowski (tpowa) - Thursday, 31 July 2014, 09:21 GMT
Latest depends need to be installed. Fixed package comes up.

Loading...