Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#4140 - Configurable time out for wpa in network profiles

Attached to Project: Arch Linux
Opened by Andy P (Phydeaux37) - Friday, 10 March 2006, 20:34 GMT
Last edited by arjan timmerman (blaasvis) - Thursday, 16 March 2006, 14:29 GMT
Task Type Feature Request
Category System
Status Closed
Assigned To James Rayner (iphitus)
Architecture not specified
Severity Low
Priority Normal
Reported Version 0.7.1 Noodle
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


It seems from some forum post that the default time out for wpa_supplicant in the network prodiles isn't long enough for some users. I've written a patch that makes the time out value configurable from the network profile. The new variable is $WPA_WAIT and defaults to 25 unless otherwise specified in the profile. The patch will modify /usr/bin/netcfg and will add some informaition about WPA_WAIT to /etc/network-profiles/template. The patch applies to initscripts version 0.7.1-20, which was in current when I wrote the patch.

This task depends upon

Closed by  James Rayner (iphitus)
Sunday, 01 April 2007, 07:51 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in network scripts GIT ork_Scripts
Comment by Rafal Szczepaniak (lanrat) - Friday, 10 March 2006, 21:05 GMT
I can confirm now that increasing the wpa timeout value helps.
Since I changed it I had 0 problems with network timeouts during boot.
It would be really cool if this was a network profile variable so I won't have
to change the netcfg script manually after each upgrade.

BTW the forum thread url
Comment by James Rayner (iphitus) - Friday, 09 February 2007, 11:49 GMT
this will be in the new network scripts. I've just added it, a TIMEOUT=? variable.