Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41357 - [shutter] 0.91-2 Launching a second instance causes first instance to crash

Attached to Project: Community Packages
Opened by Moabit (Moabit) - Saturday, 26 July 2014, 23:58 GMT
Last edited by Balló György (City-busz) - Tuesday, 24 January 2017, 12:24 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
1) Start an instance of shutter.
2) Attempt to start another instance (e.g. with a "take screenshot" hotkey, or via any other method).
3) First instance crashes; second instance doesn't start.

Impact: if users use a hotkey to take screenshots, they have to quit all running instances of shutter first. Hence, there is no easy way to take multiple screenshots rapidly.

Additional info:
* package version: 0.91-2, but this was experienced in earlier AUR versions too. I never encountered this in (K)ubuntu, and this bug appears to be specific to Arch. This thread appears to confirm this: https://bugs.launchpad.net/shutter/+bug/731874
* Output of first instance (running with --debug):
> Segmentation fault
* Output of second instance (running with --debug):
> WARNING **: Error while sending message: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus) at /usr/bin/shutter line 341, <DATA> line 19.
> INFO: There is already another instance of Shutter running!

(I tried getting the trace as per [1], but running `gdb /usr/bin/shutter` returns `"/usr/bin/shutter": not in executable format: File format not recognized`.)

[1] https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines
This task depends upon

Closed by  Balló György (City-busz)
Tuesday, 24 January 2017, 12:24 GMT
Reason for closing:  Won't fix
Additional comments about closing:  The package is moved to AUR.
Comment by Moabit (Moabit) - Sunday, 27 July 2014, 00:58 GMT
Ah, I worked out how to get the trace. (I needed to use `gdb /usr/bin/perl`, then `run /usr/bin/shutter`.)

Using gdb, the bug is slightly different. Instead of the first instance aborting, it freezes instead, but stays visible. Here are the traces after launching the second instance.

First instance:
Program received signal SIGSEGV, Segmentation fault.
0x00007ffff641a610 in g_utf8_validate () from /usr/lib/libglib-2.0.so.0

Second instance:
WARNING **: Error while sending message: Timeout was reached at /usr/bin/shutter line 341, <DATA> line 19.
INFO: There is already another instance of Shutter running!
[Thread 0x7fffe54af700 (LWP 8713) exited]
[Thread 0x7fffe5cb0700 (LWP 8712) exited]
[Inferior 1 (process 8706) exited normally]

I've also attached the full traces.
Comment by Moabit (Moabit) - Sunday, 10 August 2014, 16:16 GMT
Fixed in shutter 0.92-1.
Comment by Felix Yan (felixonmars) - Sunday, 10 August 2014, 16:28 GMT
While I hope it was fixed in 0.92-1, it still crashes here for myself :(
Comment by Moabit (Moabit) - Sunday, 10 August 2014, 16:34 GMT
Oh, I just installed 0.92-1 and it's fine for me. Being specific, I launch shutter with a keyboard shortcut bound to `shutter --full`, save that screenshot, then use the keyboard shortcut again. I'm using KDE.

It's a bit buggy if I don't save (or close?) the first screenshot before taking another; I get a blank window. Everything feels a bit slower, too…
Comment by Felix Yan (felixonmars) - Sunday, 10 August 2014, 16:46 GMT
Hrm, thanks. So `shutter --full` works for me too, but `shutter --select` and `shutter --window` causes the previous shutter instance to segfault. If you could confirm it too, this seems like an incomplete fix.
Comment by Moabit (Moabit) - Sunday, 10 August 2014, 16:56 GMT
Ah yes, good find. My situation is exactly the same. I've posted this info in the linked launchpad bug.
Comment by Moabit (Moabit) - Wednesday, 04 January 2017, 22:38 GMT
This bug has been fixed by the following patch submitted in the comments to the upstream bug.
https://bugs.launchpad.net/shutter/+bug/731874/comments/14

Loading...