Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41294 - [glibc] Minimal install - missing dependencies (e.g. locale-gen breaks without gzip/sed)

Attached to Project: Arch Linux
Opened by nfnty (nfnty) - Tuesday, 22 July 2014, 14:19 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 23 July 2014, 02:14 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Request is to add all dependencies to packages, even if those dependencies are in base. And if circular dependencies break Pacman, then at least add it as an optional for now.

Another possibility is to add a new group called "minimal" including all packages needed for the core packages to work, such as linux, bash, glibc {gzip, sed}, pacman, shadow, filesystem and maybe systemd.

A wiki page could also be added for information about minimal install.

The best scenario would be if all of these could be implemented. This is a major gripe when installing arch with the bare minimum packages. See attached mkimage.sh to understand what I mean.

---------------------------------

Duplicate of  FS#25178 . Locale-gen requires sed and localedef fails without gzip installed. The character maps at /usr/share/i18n/charmaps/ are compressed with gzip.

Additional info:
* package version(s)
2.19-5

* config and/or log files etc.
Generating locales...
en_US.UTF-8...character map file `UTF-8' not found: No such file or directory
default character map file `ANSI_X3.4-1968' not found: No such file or directory

Steps to reproduce:

See attached mkimage.sh
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 23 July 2014, 02:14 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#25178 

Loading...