Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41261 - [xf86-video-intel] Same redraw lag as #39827 but with Intel driver

Attached to Project: Arch Linux
Opened by John Lindgren (jlindgren) - Saturday, 19 July 2014, 03:33 GMT
Last edited by Laurent Carlier (lordheavy) - Thursday, 24 July 2014, 08:24 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Since the X.org 1.16 update, I'm seeing the same lagging symptoms that others saw with certain versions of the Nvidia driver:

https://github.com/chjj/compton/issues/181
https://bbs.archlinux.org/viewtopic.php?id=178024
https://bugs.archlinux.org/task/39827

Only, I am using the xf86-video-intel driver on an Intel HD 4000 chipset. Scrolling in Firefox is the easiest way to reproduce the problem. Using Compton (compton-git from AUR) in XFCE, scrolling lags by one wheel event, and will only catch up when some later action (such as moving the mouse over a link) triggers another redraw. With Compiz (compiz-gtk-standalone from AUR), the problem is more severe: the lag can extend to several wheel events, and moving the mouse over a link only redraws a small rectangle around the link, causing a "cut up" look as described in the forum thread.

With compton, the --xrender-sync-fence option fixes the problem, but as far as I can tell, that option is only a workaround and the real problem lies in the driver.

Also, the problem does not show up in a plain XFCE session with no compositor running.

Additional info:

* package version(s)

linux 3.15.6-1
xorg-server 1.16.0-2
xf86-video-intel 2.99.912-3
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Thursday, 24 July 2014, 08:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  xf86-video-intel 2.99.914-1
Comment by Roland (ubunchu) - Saturday, 19 July 2014, 23:49 GMT
I can confirm this problem (no problems if downgrading).
Since last update I noticed in Lugaru HD objects flickering; in chromium when hovering over the tabs, the window starts freezing - lagging for a brief moment while I move the mouse.
Comment by Laurent Carlier (lordheavy) - Monday, 21 July 2014, 09:58 GMT
Can you try with xf86-video-intel packages here: http://pkgbuild.com/~lcarlier/pkgtest/ ?
Packages have dri3 disabled
Comment by Laurent Carlier (lordheavy) - Monday, 21 July 2014, 20:06 GMT
And with xf86-video-intel-2.99.912-4 in testing ?
Comment by Roland (ubunchu) - Tuesday, 22 July 2014, 08:29 GMT
My mistake, I was using the latest stable versions and had those issues, though after installing driconf it was gone.
Comment by John Lindgren (jlindgren) - Tuesday, 22 July 2014, 12:49 GMT
I may not have a chance to test the new version earlier than next week. My apologies.
Comment by Aliaksandr Stelmachonak (ava1ar) - Wednesday, 23 July 2014, 04:10 GMT
Patch is available upstream to fix the issue without disabling DRI3: https://bugs.freedesktop.org/show_bug.cgi?id=81551
Tried it today and this solved the refresh problem for me.

Loading...