Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41247 - [bluez] hci0 Load Connection Parameters failed: Unknown Command (0x01)

Attached to Project: Arch Linux
Opened by Tomasz Przybył (FadeMind) - Thursday, 17 July 2014, 19:52 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 11 October 2014, 13:27 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Sven-Hendrik Haase (Svenstaro)
Giovanni Scafora (giovanni)
Tom Gundersen (tomegun)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

After installing bluedevil in KDE, enabled bluetooth service and checked bluetooth status I saw warnings:

lip 17 15:48:53 manjaro bluetoothd[649]: Sap driver initialization failed.
lip 17 15:48:53 manjaro bluetoothd[649]: sap-server: Operation not permitted (1)
lip 17 15:48:54 manjaro bluetoothd[649]: hci0 Load Connection Parameters failed: Unknown Command (0x01)

Service bluetooth working good (connection via a mobile phone and laptop and sending files) but I don't know what it is (warning or bug).
Full listing log is in attachment.

Regards.

This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 11 October 2014, 13:27 GMT
Reason for closing:  Not a bug
Additional comments about closing:  seems to be an unimportant warning.
Comment by Heinrich Siebmanns (Harvey) - Friday, 25 July 2014, 07:21 GMT
Same here. Obviously Sap is usually not present on a pc bluetooth controller. For explanation see:
http://en.wikipedia.org/wiki/SIM_Access_Profile#SIM_Access_Profile_.28SAP.2C_SIM.2C_rSAP.29
It should be possible to disable the sap server somewhere, but I did not find a place yet...
Comment by Heinrich Siebmanns (Harvey) - Sunday, 17 August 2014, 12:08 GMT
Turns out that the sap server can be disabled by overriding the stock systemd service file's ExecStart with "/usr/lib/bluetooth/bluetoothd --noplugin=sap". See the systemd wiki for further explanation regarding customexecs. The 'hci0 Load Connection Parameters failed' error is still valid and seems to be a different beast.
Comment by Andreas Radke (AndyRTR) - Sunday, 17 August 2014, 12:14 GMT
Can you please tell us why I see "Manjaro" here? Are you reporting about Manjaro packages or are you running plain Arch Linux?
Comment by Tomasz Przybył (FadeMind) - Sunday, 17 August 2014, 12:30 GMT
Manjaro based on Arch Packages directly, thats why I commiting issues here.
Comment by Andreas Radke (AndyRTR) - Sunday, 17 August 2014, 12:38 GMT
The 'hci0 Load Connection Parameters failed' error can be found since years in various distributions. It seems not critical to me.

Loading...