Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41179 - libxcursor update changed default cursors

Attached to Project: Arch Linux
Opened by Brian De Wolf (bldewolf) - Saturday, 12 July 2014, 22:42 GMT
Last edited by Jan de Groot (JGC) - Sunday, 13 July 2014, 14:39 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After updating recently, my host (which has no DE, just the WM awesome) now uses Adwaita cursors instead of the default Xorg cursors. It looks like this is because the resolution to  FS#40658  made Adwaita the default cursor set across the board, instead of just a fallback. Since my WM doesn't explicitly set a theme, it now uses Adwaita.

If the host doesn't have the Adwaita theme installed, the default Xorg cursors are still used.

My current workaround is to create a ~/.icons/default/index.theme with contents:

[Icon Theme]
Inherits=core

It's not clear if "core" is a valid theme or if I'm just inheriting from a nonexistent theme. Either way, it works around the issue.

Additional info:

libxcursor-1.1.14-2

Steps to reproduce:

Update libxcursor, install Adwaita cursor theme, use a WM that doesn't explicitly set a cursor theme, observe that the cursors are not the default Xorg cursors.
This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 13 July 2014, 14:39 GMT
Reason for closing:  Won't fix
Additional comments about closing:  This change is intented. Core theme doesn't contain all required icons.

Loading...