Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41102 - [thunar] segfaults repeatedly

Attached to Project: Arch Linux
Opened by indianahorst (indianahorst) - Saturday, 05 July 2014, 16:27 GMT
Last edited by Evangelos Foutras (foutrelis) - Saturday, 03 October 2015, 22:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Evangelos Foutras (foutrelis)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Thunar sometimes (without any specific reason) closes and all open sessions disappear.
In dmesg it is visible that Thunar crashes with an segfault, see below.

Additional info:
* package version(s)
extra/thunar 1.6.3-1 (xfce4)
extra/xfwm4 4.10.1-1 (xfce4)
core/glib2 2.40.0-1
core/glibc 2.19-5 (base)

* config and/or log files etc.
From dmesg:
[58269.530279] Thunar[742]: segfault at 378e0c0 ip 00007f2d31f19017 sp 00007fffdf0279b0 error 4 in libglib-2.0.so.0.4000.0[7f2d31eb5000+105000]


Steps to reproduce:
Open several sessions of Thunar and wait.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Saturday, 03 October 2015, 22:21 GMT
Reason for closing:  Works for me
Additional comments about closing:  See last comment if the issue persists.
Comment by Evangelos Foutras (foutrelis) - Sunday, 06 July 2014, 09:03 GMT
Do you have the latest version of gtk2 (2.24.24-1) installed?.
Comment by indianahorst (indianahorst) - Sunday, 06 July 2014, 11:15 GMT
Yes:
$ pacman -Qs gtk2
...
local/gtk2 2.24.24-1
GTK+ is a multi-platform toolkit (v2)
...
Comment by indianahorst (indianahorst) - Thursday, 17 July 2014, 23:22 GMT
Since a few days I additionaly get segfaults from "gmain", which are also crashing Thunar:

[218900.210778] gmain[8008]: segfault at d0ba03f ip 00007fa7577b9017 sp 00007fa74bc659a0 error 4 in libglib-2.0.so.0.4000.0[7fa757755000+105000]

Here somebody had a similar problem: http://forums.linuxmint.com/viewtopic.php?f=208&t=152685
Comment by indianahorst (indianahorst) - Saturday, 26 July 2014, 13:50 GMT
[201310.669224] Thunar[24178]: segfault at bffc1cb ip 00007fbd19874017 sp 00007fff88fd8fd0 error 4 in libglib-2.0.so.0.4000.0[7fbd19810000+105000]
[203774.968181] Thunar[29407]: segfault at c255bf5 ip 00007f10a518c017 sp 00007fff35520410 error 4 in libglib-2.0.so.0.4000.0[7f10a5128000+105000]

Can you please fix this problem? It is really annoying when your filemanager crashes every hour...
Comment by Jeremy LaCroix (jlacroix) - Thursday, 06 November 2014, 23:11 GMT
Same issue here, with not only Thunar but Caja as well. This is also causing MATE's desktop to repeatedly die.

Nov 06 17:44:47 trinity kernel: caja[8422]: segfault at 25342d4 ip 00007fe7b263f2f5 sp 00007fff581cfe30 error 4 in libglib-2.0.so.0.4200.0[7fe7b25d9000+10c000]

Nov 06 17:44:53 trinity systemd-coredump[8471]: Process 8422 (caja) of user 1000 dumped core.


local/gtk2 2.24.25-1

local/glib2 2.42.0-1
Comment by Evangelos Foutras (foutrelis) - Saturday, 03 October 2015, 22:21 GMT
Thunar has been very stable for me over the last couple of years, though these crashes might have been related to (un)mounting USB flash drives (which I don't use).

If this is still an issue and you can get a useful backtrace (would need debug builds of Thunar and GTK2), please file a new bug. [1]

[1] https://wiki.archlinux.org/index.php/Debug_-_Getting_Traces

Loading...