Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41084 - [firefox] update to using gtk3 and system cairo

Attached to Project: Arch Linux
Opened by Steven Honeyman (stevenhoneyman) - Friday, 04 July 2014, 08:47 GMT
Last edited by Jan de Groot (JGC) - Friday, 04 July 2014, 08:55 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Would it be possible to change to using Gtk3 for firefox? I've just learnt that there's a mozconfig entry that should do this:

"ac_add_options --enable-default-toolkit=cairo-gtk3"

(along with re-enabling system cairo - I think it's a pre-requisite for this to work)
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 04 July 2014, 08:55 GMT
Reason for closing:  Won't implement
Additional comments about closing:  Default is gtk2. Switching to gtk3 means incomplete work. This would also completely drop NPAPI support, as that depends on gtk2.

Loading...