Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41064 - [dolphin] shared-mime-info update from 1.2-2 to 1.3-1 "breaks" .iso files

Attached to Project: Arch Linux
Opened by AndrzejL (AndrzejL) - Thursday, 03 July 2014, 05:46 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 11 October 2014, 14:18 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Andrea Scarpino (BaSh)
Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Hi there.

This is an issue that is out there for quite a while (31 May 2014) although I have just recently noticed it.

shared-mime-info update from 1.2-2 to 1.3-1 "breaks" .iso files (.txt file icon / behavior).

pacman -Qi shared-mime-info

Name : shared-mime-info
Version : 1.3-1
Description : Freedesktop.org Shared MIME Info
Architecture : i686
URL : http://freedesktop.org/Software/shared-mime-info
Licenses : GPL2
Groups : None
Provides : None
Depends On : libxml2 glib2
Optional Deps : None
Required By : akonadi cmake fceux gtk2 gtk3 kdelibs libreoffice-common virtualbox
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 4104.00 KiB
Packager : CENSORED for privacy purposes.
Build Date : Sat 31 May 2014 19:16:25 IST
Install Date : Mon 30 Jun 2014 15:33:46 IST
Install Reason : Installed as a dependency for another package
Install Script : Yes
Validated By : Signature


I have found confirmation here:

https://bbs.archlinux.org/viewtopic.php?id=182287

All You have to do is upgrade as usual. Open lets say Dolphin. Browse to any folder that contains lets say Arch Linux iso. You will notice that the iso has a .txt file icon. Also if You right click on it and choose "Open With" You will get text editors.

http://postimg.org/image/d791o7urx/

Its not a major issue but it can be annoying :).

Thanks in advance.

Kind regards.

Andrzej
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 11 October 2014, 14:18 GMT
Reason for closing:  Upstream
Additional comments about closing:  not a bug in shared-mime-info.
Comment by Andreas Radke (AndyRTR) - Thursday, 03 July 2014, 19:18 GMT
Feel free to report this upstream.
Comment by AndrzejL (AndrzejL) - Thursday, 03 July 2014, 22:56 GMT
Will do.

Thanks.

Andrzej
Comment by AndrzejL (AndrzejL) - Thursday, 03 July 2014, 23:14 GMT Comment by AndrzejL (AndrzejL) - Friday, 04 July 2014, 09:37 GMT
https://bugs.kde.org/show_bug.cgi?id=337035

Turns out it could be a Dolphin regression.

Cheers.

Andrzej
Comment by jim945 (jim945) - Tuesday, 15 July 2014, 20:23 GMT Comment by Tomasz Przybył (FadeMind) - Saturday, 19 July 2014, 06:04 GMT
Fix ISO images appearing as .txt files in Dolphin: https://forum.manjaro.org/index.php?topic=15231

Proof: http://i.imgur.com/TEwMSZS.png

Regards

Loading...