Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41056 - [sqlitebrowser] 3.1.0 needs libxkbcommon-x11 as dependency

Attached to Project: Community Packages
Opened by Daniel (weirddan455) - Wednesday, 02 July 2014, 13:57 GMT
Last edited by Sergej Pupykin (sergej) - Wednesday, 02 July 2014, 14:43 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Since the update to 3.1.0 and the switch to qt5, without libxkbcommon-x11, sqlitebrowser prints the following error and refuses to run:

This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: eglfs, kms, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
Aborted

As it seems nearly every Qt5 program will require this package I first suggested it be added as a dependency of qt5-base but that was shot down:

https://bugs.archlinux.org/task/41055

citing a duplicate of https://bugs.archlinux.org/task/40468

I'm not sure why they don't want to add it as a dependency to qt5-base since it's a very small package and has few dependencies but it looks like sqlitebrowser (as well as nearly every other program that uses qt5) will have to add libxkbcommon-x11 to their dependency list.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Wednesday, 02 July 2014, 14:43 GMT
Reason for closing:  Fixed

Loading...