Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41012 - [nfs-utils] error starting nfs-blkmap.service

Attached to Project: Arch Linux
Opened by Sebastiaan Lokhorst (lonaowna) - Friday, 27 June 2014, 18:48 GMT
Last edited by Tobias Powalowski (tpowa) - Tuesday, 09 September 2014, 13:07 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

When I start nfs-client.target, I get the following error in the journal:

Dependency failed for pNFS block layout mapping daemon.

Despite of this error, nfs-client.target seems to start fine anyway. (everything works as expected)

It looks like this error was introduced with nfs-utils 1.3.0. I am currently running 1.3.0-2.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Tuesday, 09 September 2014, 13:07 GMT
Reason for closing:  Not a bug
Comment by Bernd Butscheidt (berndb) - Sunday, 29 June 2014, 09:09 GMT
same issue here
Comment by Tobias Powalowski (tpowa) - Sunday, 29 June 2014, 19:15 GMT
This is not a bug, it fails because you don't need it. To avoid such errors you can mask the service file.
The blkmapd daemon performs device discovery and mapping for the parallel NFS (pNFS) block layout client [RFC5663]
Comment by Sebastiaan Lokhorst (lonaowna) - Sunday, 29 June 2014, 19:44 GMT
Thanks for taking the time to explain.

However, even when I do not need it, I think an error like this is ugly and should be handled better. This is the only red and bold error in my entire journal, from boot to shutdown.

On a side note, if I would want to use blkmapd, how would I use it? Right now it fails with "open pipe file /var/lib/nfs/rpc_pipefs/nfs/blocklayout failed: No such file or directory".
Comment by Tobias Powalowski (tpowa) - Thursday, 03 July 2014, 07:15 GMT
From nfs-utils README:
nfs-server.service
If enabled, nfs service is started together with dependencies
such as mountd, statd, rpc.idmapd
This is a "service" file rather than a "target" (which is the
normal grouping construct) so that
systemctl start nfs-server
can work (if no type is given, ".service" is assumed).

nfs-client.target
If enabled, daemons needs for an nfs client are enabled.
This does *not* include rpc.statd. the rpc-statd.service unit
is started by /usr/sbin/start-statd which mount.nfs will run
if statd is needed.

nfs-blkmap.target
If enabled, then blkmapd will be run when nfs-client.target is
started.

Check your /etc/systemd/system/multi-user directory if you have it enabled.
Comment by Sebastiaan Lokhorst (lonaowna) - Thursday, 03 July 2014, 22:32 GMT
Okay.. I still don't quite understand what dependency of nfs-blkmapd is failing, but if this is upstream design then I guess that there is little to do about it.
I guess this can be closed. Thanks again for the explanation!

Loading...