Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41010 - [filesystem] Shipped /etc/{group,gshadow} are out of sync

Attached to Project: Arch Linux
Opened by Alain Kalker (ackalker) - Friday, 27 June 2014, 16:34 GMT
Last edited by Dave Reisner (falconindy) - Friday, 27 June 2014, 16:43 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

As remarked by Davor Rotim (drot) in  FS#40970  : after a fresh install, running `grpck` asks for some systemd-related groups to be added to /etc/gshadow.

This is because the shipped files are out of sync: /etc/group containins more groups than /etc/gshadow.
Also, the install script will only update /etc/gshadow when it adds a group which was not in /etc/group before, which in this case doesn't happen.

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
- Do a fresh install
- Run: grpck
This task depends upon

Closed by  Dave Reisner (falconindy)
Friday, 27 June 2014, 16:43 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#40953 

Loading...