Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41009 - [unzip] mangles files

Attached to Project: Arch Linux
Opened by Guillaume BROGI (guiniol) - Friday, 27 June 2014, 14:54 GMT
Last edited by Gaetan Bisson (vesath) - Sunday, 29 June 2014, 19:13 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Unzip does not properly unzip some zip archives.
The archive has been properly downloaded and the checksums match. When unzipped on an Archlinux system (I tried three different ones) I get a "bad CRC" error and the resulting files are corrupt. This does not happen on non Archlinux systems using the same version of unzip (I tried on a Debian).


Additional info:
* package version(s): unzip 6.0-6


Steps to reproduce:
1) download this file: http://www.vacommunity.org/dl335
2) unzip downloaded file
Expected result: The files in the archive are not corrupted.
Actual result: The files in thea archive are corrupted and unzip complains that the CRCs are bad.

As far as I can tell, this problem has not been reported upstream and is specific to Archlinux, which is why I am reporting it here.
This task depends upon

Closed by  Gaetan Bisson (vesath)
Sunday, 29 June 2014, 19:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  unzip-6.0-7 in [extra]
Comment by Andrew Gaydenko (student975) - Friday, 27 June 2014, 15:22 GMT
Confirming. Under VirtualBox Mint guest unzipping is OK (also v.6.00).
Comment by Gaetan Bisson (vesath) - Sunday, 29 June 2014, 17:30 GMT
It appears Arch's unzip swaps some bytes around: when it should deflate "07.mspx][Xref => http://cgi.nessus.org/plugins/dump.php3?id=12065][Xref => http:", it actually deflates "07.mspx][35][Xref => http://www.securityfocus.com/bid/9633]..4/6/2012 17:> http:" (with the .. being \0d\0a). Fun stuff. :)
Comment by Gaetan Bisson (vesath) - Sunday, 29 June 2014, 17:33 GMT
Hum, clearing the CFLAGS does not fix this, it just gives another (still wrong) CRC... :\
Comment by Gaetan Bisson (vesath) - Sunday, 29 June 2014, 19:13 GMT
I revamped our PKGBUILD a bit, using some bits from Debian's, and it mysteriously unbroke.

Loading...