Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40956 - [qt5-base] libqxcb.so link error, missing dep.: libxkbcommon-x11

Attached to Project: Arch Linux
Opened by Vasya Pupkin (shahid) - Tuesday, 24 June 2014, 05:54 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 24 June 2014, 14:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
There is a missing dependency for qt5-base: libxkbcommon-x11.
$ ldd /usr/lib/qt/plugins/platforms/libqxcb.so | grep -i found
libxkbcommon-x11.so.0 => not found
Qt5-based apps simply doesn't run at all.
Installing package libxkbcommon-x11 by hands fixes this problem with qt5 apps.


Additional info:
* package version(s)
qt5-base 5.3.0-3
xcb-util 0.3.9-1
libxcb 1.10-2


Steps to reproduce:
1. $ yaourt -S tox-qt-git
2. $ tox-qt
This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: eglfs, kms, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
Аварийный останов (core dumped)
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 24 June 2014, 14:14 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Tuesday, 24 June 2014, 14:13 GMT
It's there:
libxkbcommon-x11 (optional) - xcb plugin

If your package needs it specifically, add the dep there.

Loading...