Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40952 - [linux] 3.15.1-1: Error "[drm:cpt_serr_int_handler] *ERROR* PCH transcoder A FIFO underrun" on boot

Attached to Project: Arch Linux
Opened by Martin Schnitkemper (Martin-MS) - Monday, 23 June 2014, 18:27 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 17 April 2016, 14:06 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 49
Private No

Details

Description: After upgrade to version 3.15.1-1 I get a "[drm:cpt_serr_int_handler] *ERROR* PCH transcoder A FIFO underrun" on every boot. It seems that only Intel-Ivy-Bridge-boards are affected. Version 3.14.6-1 has not this issue.

Additional info: After each reboot KDE reports that an audio equipment such as "HDA Intel PCH (ALC892 Analog)" or "HDA Intel PCH, ALC892 Analog (2.1 surround output, front and subwoofer speakers)" is missing, even if the devices are present and working.

Steps to reproduce: Update to kernel version 3.15.1-1
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 17 April 2016, 14:06 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 4.5-1
Comment by Karolj Kočmaroš (karlosmunjos) - Wednesday, 02 July 2014, 09:51 GMT
My CPU is also ivy-bridge and I have this error to. Also I use KDE but everything is fine with audio equipment.
Comment by Max Rohland (Felsenmann) - Thursday, 07 August 2014, 12:12 GMT
I have this Bug on my Ivy Bridge Laptop as well as on my Sandy Bridge Desktop. Sound is okay.
Comment by Samim (psamim) - Friday, 08 August 2014, 10:05 GMT
I am on 3.15.8-1, sandy-bridge, i5 3317U, same issue.
Comment by Tobias Powalowski (tpowa) - Wednesday, 13 August 2014, 07:13 GMT
Status on 3.16?
Comment by Rudolf Tilgass (rudzha) - Wednesday, 13 August 2014, 11:18 GMT
With 3.16 I get two of these now.
[drm:cpt_set_fifo_underrun_reporting] *ERROR* uncleared pch fifo underrun on pch transcoder A
[drm:cpt_serr_int_handler] *ERROR* PCH transcoder A FIFO underrun
Comment by Philipp Wolfer (phw) - Thursday, 14 August 2014, 07:38 GMT
3.16, and I get even more messages than with 3.15:

[drm:ivybridge_set_fifo_underrun_reporting] *ERROR* uncleared fifo underrun on pipe B
[drm:ivb_err_int_handler] *ERROR* Pipe B FIFO underrun
[drm:cpt_set_fifo_underrun_reporting] *ERROR* uncleared pch fifo underrun on pch transcoder A
[drm:cpt_serr_int_handler] *ERROR* PCH transcoder A FIFO underrun
[drm:cpt_set_fifo_underrun_reporting] *ERROR* uncleared pch fifo underrun on pch transcoder B
[drm:cpt_serr_int_handler] *ERROR* PCH transcoder B FIFO underrun

All I could find about it were the discussions at:
http://patchwork.freedesktop.org/patch/25875/
https://lkml.org/lkml/2014/5/5/56
Comment by Zdravko Yanakiev (z.yan) - Friday, 15 August 2014, 09:40 GMT
This error first appeared for me after upgrading to kernel 3.16:

[drm:ilk_display_irq_handler] *ERROR* Pipe A FIFO underrun
[drm:cpt_set_fifo_underrun_reporting] *ERROR* uncleared pch fifo underrun on pch transcoder A
[drm:cpt_serr_int_handler] *ERROR* PCH transcoder A FIFO underrun

I'm on a Sandy Bridge laptop (Intel Core i3-2348m). There are no visible regressions whatsoever, except for the error message.
Comment by Felix Laurie von Massenbach (erbridge) - Thursday, 28 August 2014, 19:55 GMT
I've had this as well, running on Intel(R) Core(TM) i7-3610QM CPU @ 2.30GHz.

[drm:cpt_set_fifo_underrun_reporting] *ERROR* uncleared pch fifo underrun on pch transcoder A
[drm:cpt_serr_int_handler] *ERROR* PCH transcoder A FIFO underrun

Boot also hangs sometimes around that point, though that might be a separate issue.
Comment by Nicola (drakkan) - Thursday, 28 August 2014, 20:52 GMT
for me a bios update solved errors
Comment by Oliver Warner (Arucarn) - Thursday, 18 September 2014, 07:32 GMT
I Also have this. On Kernel 3.16.2 as well. It make the boot hang for about 10 seconds which is quite annoying.
I have a Core i3 Ivy Bridge.
Comment by david (Lord David III.) - Friday, 19 September 2014, 12:32 GMT
same issue for me with Intel Celeron 1007U also Ivy Bridge on kernel 3.16.3
Comment by Martin Schnitkemper (Martin-MS) - Saturday, 20 September 2014, 09:42 GMT
Got also this error

| [drm:cpt_set_fifo_underrun_reporting] *ERROR* uncleared pch fifo underrun on pch transcoder A

in addition the the reported one after upgrade to kernel 3.16. Boot continues and does not hang, just get these messages on every boot.
Comment by Leonard König (LeonardK) - Wednesday, 24 September 2014, 08:51 GMT
Same here on i5 ivy:
> [drm:cpt_set_fifo_underrun_reporting] *ERROR* uncleared pch fifo underrun on pch transcoder A
> [drm:cpt_serr_int_handler] *ERROR* PCH transcoder A FIFO underrun

I have a Realtek Soundcard, too -anyone else?
Comment by Jun Lee (junlee) - Friday, 26 September 2014, 02:10 GMT
I also this errors.

[drm:cpt_set_fifo_underrun_reporting] *ERROR* uncleared pch fifo underrun on pch transcoder A
[drm:cpt_serr_int_handler] *ERROR* PCH transcoder A FIFO underrun

My CPU is Intel® Core™ i7-3537U CPU @ 2.00GHz and kernel 3.16.3 as well.

How can i solve these errors.
Comment by Sergey Pooheer (svp) - Saturday, 27 September 2014, 10:10 GMT
My laptop is Lenovo ThinkPad X230, BIOS update solve the problem
Comment by Colin Keenan (colinkeenan) - Monday, 29 September 2014, 17:00 GMT
I am getting the same errors:

[drm:cpt_serr_int_handler] *ERROR* PCH transcoder A FIFO underrun
[drm:cpt_set_fifo_underrun_reporting] *ERROR* uncleared pch fifo underrun on pch transcoder A

I have a Core i5, but if the problem has been solved for others by updating the bios, then that's what's important here.

I've got GA-Z77N-WIFI motherboard with version F2 of the bios from 2012. I found version F3 from 2013 at http://www.gigabyte.no/products/page/mb/ga-z77n-wifirev_10/download/, but I'm afraid to flash the bios on a computer that is working just fine. It's a big risk just to eliminate some error messages that don't seem to be effecting me in any way.

There must be a better way to fix this issue.
Comment by Leonard König (LeonardK) - Monday, 29 September 2014, 17:46 GMT
fixed it via installing the latest kernel from git -at least it seems to be fixed for now O.o
Comment by Tolga Cakir (tolga9009) - Monday, 06 October 2014, 16:35 GMT
Linux 3.16.3-1 fixed it for me.
Comment by Martin Schnitkemper (Martin-MS) - Monday, 06 October 2014, 21:58 GMT
Here not... have Linux 3.16.3-1 installed and get still these errors on boot.
Comment by Colin Keenan (colinkeenan) - Monday, 06 October 2014, 22:13 GMT
Not sure if the errors went away on 3.16.3, but I'm getting the same errors with Linux 3.16.4-1 installed.
Comment by Max Rohland (Felsenmann) - Tuesday, 14 October 2014, 22:32 GMT
A BIOS Update on my Asus P8Z68-V Pro/Gen3 solved the issue for me (Linux 3.16.4)
Comment by Tomasz Przybył (FadeMind) - Friday, 24 October 2014, 15:16 GMT
Error still present in 3.17.1-1-ARCH

[ 1.427470] [drm:cpt_set_fifo_underrun_reporting] *ERROR* uncleared pch fifo underrun on pch transcoder A
[ 1.427471] [drm:cpt_serr_int_handler] *ERROR* PCH transcoder A FIFO underrun

[ 0.000000] SMBIOS 2.7 present.
[ 0.000000] DMI: ASUSTeK COMPUTER INC. K55VM/K55VM, BIOS K55VM.211 09/11/2012
[ 8.972868] asus_wmi: BIOS WMI version: 7.9

[ 0.064260] Performance Events: PEBS fmt1+, 16-deep LBR, IvyBridge events, full-width counters, Intel PMU driver.



Comment by melgaardbjorn (melgaardbjorn) - Tuesday, 18 November 2014, 18:08 GMT
Error still present in 3.17.3-1-ARCH

[ 1.074530] [drm:cpt_set_fifo_underrun_reporting] *ERROR* uncleared pch fifo underrun on pch transcoder A
[ 1.074532] [drm:cpt_serr_int_handler] *ERROR* PCH transcoder A FIFO underrun
Comment by Tomasz Przybył (FadeMind) - Wednesday, 19 November 2014, 20:51 GMT Comment by Stephen (httpe) - Wednesday, 26 November 2014, 10:47 GMT
I also came across this error, and a BIOS update for ASUS laptop(Vesion 233, released on October 8th) fixed it.
Comment by Stephen (httpe) - Thursday, 27 November 2014, 02:45 GMT
Oops, I find that it is just hidded behind a bunch of messages, but still there!(After a BISO update and kernel updated to 3.17.4-1.)
[ 14.682343] [drm:cpt_set_fifo_underrun_reporting] *ERROR* uncleared pch fifo underrun on pch transcoder A
[ 14.682345] [drm:cpt_serr_int_handler] *ERROR* PCH transcoder A FIFO underrun
Comment by alsoijw (alsoijw) - Saturday, 29 November 2014, 13:17 GMT
Linux 3.17.4-1-ARCH #1 SMP PREEMPT Fri Nov 21 21:14:42 CET 2014 x86_64 GNU/Linux
The problem remains.
Comment by Marc Rechté (mrechte) - Saturday, 06 December 2014, 10:21 GMT
Linux 3.17.4-1-ARCH #1 SMP PREEMPT Fri Nov 21 21:14:42 CET 2014 x86_64 GNU/Linux
Upgraded BIOS (Gigabyte) to latest H77MD3H.F14. Still the same message.
Comment by Tomasz Przybył (FadeMind) - Tuesday, 16 December 2014, 21:05 GMT
Changes in 3.19RC1 release series:

Daniel Vetter (107):
(...)
drm/i915: Extract intel_fifo_underrun.c
drm/i915: Use dev_priv in public intel_fifo_underrun.c functions
drm/i915: Add wrappers to handle fifo underrun interrupts
drm/i915: Filter gmch fifo underruns in the shared handler
drm/i915: kerneldoc for intel_fifo_underrun.c[/b]
(...)

Main diference in 3.19RC1 is change reporting FIFO DRM issue:

In 3.18 and older was:

[ 1.212149] [drm:cpt_set_fifo_underrun_reporting] *ERROR* uncleared pch fifo underrun on pch transcoder A
[ 1.212150] [drm:cpt_serr_int_handler] *ERROR* PCH transcoder A FIFO underrun

In 3.19 series is:

[ 1.339433] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[ 1.339470] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun

not solved.
Comment by Michel (neumino) - Monday, 02 March 2015, 08:19 GMT
For what it's worth, I used to have the same error when trying to log-in in Lightdm.
I had a symbolic link from .xprofile to .xinitrc that was triggering this error. Removing it worked for me.
Comment by Maurizio D'Addona (mauritiusdadd) - Monday, 02 March 2015, 10:04 GMT
For the record, the bug has been reported upstream: https://bugzilla.kernel.org/show_bug.cgi?id=79261
Comment by David Kremer (dkremer) - Sunday, 15 March 2015, 11:31 GMT
Happening as well on a recent kernel : 3.18.6-1-ARCH #1 SMP PREEMPT Sat Feb 7 08:44:05 CET 2015 x86_64 GNU/Linux

[ 3.755255] Console: switching to colour frame buffer device 160x48
[ 3.755306] [drm:ivybridge_set_fifo_underrun_reporting] *ERROR* uncleared fifo underrun on pipe B
[ 3.755308] [drm:ivb_err_int_handler] *ERROR* Pipe B FIFO underrun
[ 3.755325] [drm:cpt_set_fifo_underrun_reporting] *ERROR* uncleared pch fifo underrun on pch transcoder B
[ 3.755326] [drm:cpt_serr_int_handler] *ERROR* PCH transcoder B FIFO underrun
[ 3.762664] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[ 3.762666] i915 0000:00:02.0: registered panic notifier
Comment by Dominik Schrempf (dschrempf) - Sunday, 26 April 2015, 12:08 GMT
Same on Thinkpad X230

Linux schwarzbaer 3.19.3-3-ARCH #1 SMP PREEMPT Wed Apr 8 14:10:00 CEST 2015 x86_64 GNU/Linux

[ 7.624473] fbcon: inteldrmfb (fb0) is primary device
[ 7.788102] psmouse serio1: synaptics: Touchpad model: 1, fw: 8.1, id: 0x1e2b1, caps: 0xd002a3/0x940300/0x123800, board id: 1611, fw id: 1099905
[ 7.788117] psmouse serio1: synaptics: serio: Synaptics pass-through port at isa0060/serio1/input0
[ 7.825262] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input122
[ 7.872466] mousedev: PS/2 mouse device common for all mice
[ 7.902914] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[ 7.902975] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
[ 8.336977] intel_rapl: Found RAPL domain package
[ 8.336978] intel_rapl: Found RAPL domain core
[ 8.336979] intel_rapl: Found RAPL domain uncore
[ 8.387869] Console: switching to colour frame buffer device 170x48
[ 8.392198] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
Comment by Dom (dom) - Wednesday, 06 May 2015, 07:48 GMT
Still no improvement on kernel 4.0.1-1 on my Thinkpad T420 with Intel Sandy Bridge i5-2520M. So not only Ivy Bridge is affected.

[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
Comment by Dan Andresan (forumache) - Wednesday, 06 May 2015, 08:14 GMT
Funny, on my home computer i7 Ivy Bridge the message dissapeared with kernel 4.0.1
On the other hand, on my work computer i3 1st generation, where I did not have the message, it appeared with kernle 4.0.1

Win some, loose some, I guess ...
Comment by Mohammad H. Amir Amjadi (nixmd) - Friday, 03 July 2015, 19:19 GMT
Here, Lenovo ThinkPad Edge E531 and kernel 4.0.6-1, seeing this error not during the boot but during my work and display suddenly becomes messy with some horizontal white lines
Jul 03 10:34:55 MyPC kernel: [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
Jul 03 10:34:55 MyPC kernel: [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
Comment by Ycny Julkinen (ycny) - Tuesday, 21 July 2015, 06:35 GMT
Linux *** 4.1.2-2-ARCH #1 SMP PREEMPT Wed Jul 15 08:30:32 UTC 2015 x86_64 GNU/Linux
HP ProBook 640 G1 - Intel Haswell

[drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
[drm:intel_set_cpu_fifo_underrun_reporting [i915]] *ERROR* uncleared fifo underrun on pipe B
[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun
Comment by John Henderson (jwhendy) - Monday, 27 July 2015, 20:40 GMT
Just got these messages twice today on separate resumes from suspend to RAM. No obvious way to un-freeze it, so I had to hard kill and start fresh. HP Zbook 15, i7-4810MQ (Haswell) with integrated Intel HD Graphics 4600 and discrete Nvidia Quadro K2100M. Linux ## 4.1.2-2-ARCH #1 SMP PREEMPT Wed Jul 15 08:30:32 UTC 2015 x86_64 GNU/Linux.
Comment by Tom Tobin (tomxtobin) - Friday, 07 August 2015, 14:08 GMT
Noticed another ThinkPad X230 user above claiming a BIOS update solved the issue for them. I'm also on a ThinkPad X230 and the latest BIOS (v2.64 / G2ETA4WW), and still seeing this issue.
Comment by Artur Lange (arc2) - Friday, 02 October 2015, 05:33 GMT
IdeaPad Y580, 4.1.6-1-ARCH, also having

[drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
Comment by Tomasz Przybył (FadeMind) - Thursday, 05 November 2015, 09:05 GMT
$ uname -a
Linux arch 4.3.0-1-ARCH #1 SMP PREEMPT Mon Nov 2 16:52:35 CET 2015 x86_64 GNU/Linux

$ dmesg |grep DMI:
[ 0.000000] DMI: ASUSTeK COMPUTER INC. K55VM/K55VM, BIOS K55VM.211 09/11/2012

$ dmesg|grep ERROR
[ 1.379221] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[ 1.379264] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun

$ lspci|grep VGA |grep Intel
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
Comment by jon doe (harh12) - Friday, 13 November 2015, 19:52 GMT
I have a HP dv7 notebook. BIOS update,, still have error

[drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun

[drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder B
[drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder B FIFO underrun
Comment by Srikanth Anantharam (sria91) - Monday, 28 December 2015, 02:22 GMT
On my Samsung Laptop with Intel Core i5 I get the following error:

[ 14.621572] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[ 14.621614] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
Comment by ybsar (ybsar) - Thursday, 14 January 2016, 09:25 GMT
I have the same error for months, that is after upgrading to linux 4.0.2-1.

$ dmesg | grep '\<PCH\>' -i
[ 1.341049] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input12
[ 1.341083] input: HDA Intel PCH Front Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input13
[ 1.341113] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input14
[ 1.708821] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[ 1.708864] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun

$ lspci | grep '00:1b'
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)

$ dmesg | grep '\<DMI\>'
[ 0.000000] DMI: CLEVO CO. W110ER /W110ER , BIOS 4.6.5 05/25/2012

$ uname -a
Linux *** 4.3.3-2-ARCH #1 SMP PREEMPT Wed Dec 23 20:09:18 CET 2015 x86_64 GNU/Linux
Comment by Max (mjal) - Monday, 18 January 2016, 15:24 GMT
These errors are fixed on my computer by the microcode update (https://wiki.archlinux.org/index.php/microcode).
Did you try that ?
Comment by Colin Keenan (colinkeenan) - Monday, 18 January 2016, 16:34 GMT
I run intel (core i5) and many months (years?) ago there was news on archlinux.org telling you how to do the microcode update. I did it back then. I still have these errors.
Comment by Tomasz Przybył (FadeMind) - Monday, 18 January 2016, 16:39 GMT Comment by John Henderson (jwhendy) - Tuesday, 19 January 2016, 00:22 GMT
@Tomasz: just upgraded to the 2015-11 version of intel-ucode you linked to and will post back in a couple weeks to see if this solves it. I can't reliably reproduce, but it seems to happen when I have numerous suspend/resume cycles. I'd want to have some decent uptime to comment on an effect.
Comment by ybsar (ybsar) - Sunday, 24 January 2016, 15:37 GMT
I have just updated the microcode, see below. I still have the above errors.

$ dmesg | grep -i microcode
[ ] microcode: CPU0 microcode updated early to revision 0x1b, date = 2014-05-29
[ ] microcode: CPU1 microcode updated early to revision 0x1b, date = 2014-05-29
[ ] microcode: CPU0 sig=0x306a9, pf=0x10, revision=0x1b
[ ] microcode: CPU1 sig=0x306a9, pf=0x10, revision=0x1b
[ ] microcode: CPU2 sig=0x306a9, pf=0x10, revision=0x1b
[ ] microcode: CPU3 sig=0x306a9, pf=0x10, revision=0x1b
[ ] microcode: Microcode Update Driver: v2.00

P.S. not better with revision 0x1c, date = 2015-02-26
Comment by Tomasz Przybył (FadeMind) - Sunday, 24 January 2016, 16:01 GMT
I have lastest microcode for my CPU and FIFO underrun issue still exists on Linux 4.4.

[ 0.000000] microcode: CPU0 microcode updated early to revision 0x1c, date = 2015-02-26
[ 0.060013] microcode: CPU1 microcode updated early to revision 0x1c, date = 2015-02-26
[ 0.074062] microcode: CPU2 microcode updated early to revision 0x1c, date = 2015-02-26
[ 0.088129] microcode: CPU3 microcode updated early to revision 0x1c, date = 2015-02-26
[ 0.638388] microcode: CPU0 sig=0x306a9, pf=0x10, revision=0x1c
[ 0.638393] microcode: CPU1 sig=0x306a9, pf=0x10, revision=0x1c
[ 0.638401] microcode: CPU2 sig=0x306a9, pf=0x10, revision=0x1c
[ 0.638408] microcode: CPU3 sig=0x306a9, pf=0x10, revision=0x1c
[ 0.638415] microcode: CPU4 sig=0x306a9, pf=0x10, revision=0x1c
[ 0.638423] microcode: CPU5 sig=0x306a9, pf=0x10, revision=0x1c
[ 0.638432] microcode: CPU6 sig=0x306a9, pf=0x10, revision=0x1c
[ 0.638439] microcode: CPU7 sig=0x306a9, pf=0x10, revision=0x1c
[ 0.638482] microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba
Comment by ybsar (ybsar) - Wednesday, 27 January 2016, 10:01 GMT
I sometimes get the following error message, though I cannot reproduce it systemically for now:

ALSA lib pcm.c:7963:(snd_pcm_recover) underrun occurred

Installed packages: alsa-lib 1.1.0-1 , pulseaudio 8.0-1 , pulseaudio-alsa 2-3
Active systemd services: alsa-restore.service

Most of related threads involve HDA Intel controller too:
https://bbs.archlinux.org/viewtopic.php?id=145570
https://bbs.archlinux.org/viewtopic.php?id=185736
http://thehumble.ninja/2014/02/06/fixing-alsa-lib-pcmc7843snd_pcm_recover-underrun-occurred-while-keeping-pulseaudio-in-your-system/

In the last thread, part of a workaround is to ignore the on-board HDA Intel controller by disabling the udev automatic detection.
Comment by John Henderson (jwhendy) - Tuesday, 02 February 2016, 15:50 GMT
Replying back after trying updated microcode:

# pacman -Qi intel-ucode
Name : intel-ucode
Version : 20151106-1

Still getting the errors:

[106241.296144] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[106241.296165] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
[106243.169718] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[106243.169724] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun

Related to ybsar's commet, I wonder if it surrounds audio as well. I watched a movie last night using an external bluetooth speaker. I have wondered if this occurs based on some combination of: btusb modprobed, bluetooth service running, pulseaudio running? Then again, I got these errors before I had the speaker and had ever used bluetooth on this system. In any case, it's not the microcode in my case. Also, for me this is only on resume, never on boot.
Comment by ybsar (ybsar) - Wednesday, 03 February 2016, 07:36 GMT
Now using to linux 4.4.1-1 and linux-firmware 20160113.40e9ae8-1 the following error sometimes occurs (again not systematically):

kernel: i915 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment

Complementary notes: I only have internal speakers, no other sound controller, and both error messages are not related to the suspend/resume in my case.
Comment by Jason Antman (jantman) - Monday, 15 February 2016, 22:55 GMT
I'm having a very similar issue, but with "transcoder B" not "transcoder A". I opened https://bugs.archlinux.org/task/47937 for my issue.

Hardware:

Gigabyte GA-Z77-D3H rev 1.2, BIOS FA (rev 4.6) (latest non-beta), Intel Z77 Express chipset
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09) (prog-if 00 [VGA controller])

The issue **first** happened when updating from linux-4.2.5-1 and xf86-video-intel-1:2.99.917+478+gdf72bc5-3 to linux-4.3.3-3 and xf86-video-intel-1:2.99.917+519+g8229390-1. I rolled that update back (xf86-video-intel and linux and related kernel packages) and the bug was gone.

There's no BIOS update available for my board, except one marked as a Beta, which I'm not installing. I attempted and confirmed a microcode update, but no change. The bug only happens when driving my second (HDMI) monitor at full native resolution. Dropping resolution fixes it, but makes it unusable for me.

Today I just did a full update again, which included:
xf86-video-intel (1:2.99.917+478+gdf72bc5-3 -> 1:2.99.917+519+g8229390-1)
linux (4.2.5-1 -> 4.4.1-2)

And the issue is back. I'll be downgrading again.
Comment by BP (kichawa) - Tuesday, 23 February 2016, 14:00 GMT
[ 472.264880] perf interrupt took too long (2517 > 2495), lowering kernel.perf_event_max_sample_rate to 50100
[ 1312.872889] perf interrupt took too long (4991 > 4960), lowering kernel.perf_event_max_sample_rate to 25200
[ 2512.805263] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[ 2512.805926] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun

00:02.0 0300: 8086:0046 (rev 02) (prog-if 00 [VGA controller])
Subsystem: 17aa:215a
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0
Interrupt: pin A routed to IRQ 24
Region 0: Memory at f2000000 (64-bit, non-prefetchable) [size=4M]
Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256M]
Region 4: I/O ports at 1800 [size=8]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: i915
Kernel modules: i915
Comment by ybsar (ybsar) - Sunday, 17 April 2016, 06:37 GMT
The 4.5-1 update solved the issue for me.
Comment by Tomasz Przybył (FadeMind) - Sunday, 17 April 2016, 07:18 GMT
I confirm:

4.5 kernel series don't have DRM i915 FIFO underrun ERROR issue anymore.

$ sudo dmidecode | grep -e Date -e Vendor -e Version -e Product | head -n 4
Vendor: American Megatrends Inc.
Version: K55VM.211
Release Date: 09/11/2012
Product Name: K55VM
Comment by Martin Schnitkemper (Martin-MS) - Sunday, 17 April 2016, 14:03 GMT
Same here, didn't got this message anymore after upgrade to kernel 4.5

Loading...