Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40926 - [xorg-server] Xserver values are changed after waking up from suspension/sleep

Attached to Project: Arch Linux
Opened by Amitav (amitavmohanty01) - Saturday, 21 June 2014, 17:21 GMT
Last edited by Jan de Groot (JGC) - Friday, 10 July 2015, 08:32 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
After waking up from sleep/suspension, sometimes xorg parameters appear changed. I am not sure what component is at fault here. The property I monitored was keyboard repeat rate.

# before sleep
>xset q | grep rate
auto repeat delay: 250 repeat rate: 30

# after sleep
>xset q | grep rate
auto repeat delay: 660 repeat rate: 25

Additional info:
* package version(s)
xorg-server 1.15.1-1
linux 3.15.1-1
systemd 213-9
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 10 July 2015, 08:32 GMT
Reason for closing:  Not a bug
Additional comments about closing:  See last comment. gnome-settings-daemon re-applies keyboard settings from dconf on resume or whenever a new keyboard device is attached.
Comment by Doug Newgard (Scimmia) - Friday, 27 June 2014, 22:10 GMT
I have no idea where the issue is, so we'll just start at the top most package on the list.
Comment by Dave Reisner (falconindy) - Saturday, 28 June 2014, 12:10 GMT
Sometimes? But not others? I don't think any of the packages you've listed are relevant. Do you use a full desktop environment (gnome, kde, etc) or just a window manager?
Comment by Amitav (amitavmohanty01) - Sunday, 29 June 2014, 03:38 GMT
I am using KDE.

kdelibs 4.13.2-3
kdebase-runtime 4.13.2-1
kdebase-workspace 4.11.10-1
polkit-kde 0.99.0-3
systemd-sysvcompat 213-9

This problem has persisted more than 6 months btw.
Comment by Amitav (amitavmohanty01) - Monday, 01 September 2014, 11:51 GMT
Does anyone have any ideas of where to look for the reason of this issue? I am try producing debug reports with debug packages if required; but I don't know where to start looking.
Comment by Todo ays (entodoays) - Monday, 13 April 2015, 06:51 GMT
I have a similar issue. I use a custom .conf file in /etc/X11/xorg.conf.d/ and it is ignored after waking from sleep. I tried /usr/share/X11/xorg.conf.d/ as a location for the .conf file with the same results.
Comment by Jan de Groot (JGC) - Monday, 13 April 2015, 06:56 GMT
Both GNOME and KDE have their own settings for keyboard repeat rate, does the change persist when you change it in the desktop settings? Probably the settings are re-applied after resume, but as setting them with xset doesn't store those settings in GNOME or KDE means settings are reverted to default.

Loading...