Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40902 - [linux] bluetooth unusable

Attached to Project: Arch Linux
Opened by mark (qinohe) - Thursday, 19 June 2014, 22:53 GMT
Last edited by Laurent Carlier (lordheavy) - Thursday, 31 July 2014, 23:09 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 13
Private No

Details

Description:Upgrading linux (3.14.6-1 -> 3.15.1-1) leaves bluetooth ath3k unusable.
[code]dmesg|grep Bluetooth
[ 3.438010] Bluetooth: Core ver 2.19
[ 3.438033] Bluetooth: HCI device and connection manager initialized
[ 3.438041] Bluetooth: HCI socket layer initialized
[ 3.438043] Bluetooth: L2CAP socket layer initialized
[ 3.438053] Bluetooth: SCO socket layer initialized
[ 8.425489] Bluetooth: Can't get version to change to load ram patch err
[ 8.425501] Bluetooth: Loading patch file failed[/code]

Steps to reproduce:Ugrade

Patch:Patch was found https://bugzilla.kernel.org/attachment.cgi?id=140051&action=diff

Attached patch for Arch

This task depends upon

Closed by  Laurent Carlier (lordheavy)
Thursday, 31 July 2014, 23:09 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 3.15.7-1
Comment by mark (qinohe) - Saturday, 21 June 2014, 08:41 GMT
This was my first attempt to build my own kernel, and my first submitted patch, the reason why I'd build the kernel in the first place.
I would like to know, is this enough for the devs, to temporarily fix the problem, or would you need something more?
It's not about 'if' you go use the patch, but if it is okay, if you would use it. Thanks, qinohe.
Comment by Boris Momčilović (User) - Saturday, 28 June 2014, 15:44 GMT
Issue is present in latest (3.15.2) as well

[ 8.890376] Bluetooth: Core ver 2.19
[ 8.890391] Bluetooth: HCI device and connection manager initialized
[ 8.890399] Bluetooth: HCI socket layer initialized
[ 8.890402] Bluetooth: L2CAP socket layer initialized
[ 8.890417] Bluetooth: SCO socket layer initialized
[ 10.154866] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 10.154870] Bluetooth: BNEP filters: protocol multicast
[ 10.154877] Bluetooth: BNEP socket layer initialized
[ 13.890830] Bluetooth: Can't get version to change to load ram patch err
[ 13.890835] Bluetooth: Loading patch file failed
Comment by mark (qinohe) - Saturday, 28 June 2014, 18:06 GMT
Situation unchanged for 3.15.2-1-linux
Just updated to 3.15.2-1-custom with patch, I have bluetooth, patch works.
Though, I guess this is an upstream bug...
Comment by mark (qinohe) - Sunday, 29 June 2014, 15:07 GMT
I see, you can't edit the actual task.
After finding what went wrong to this commit, see link in commit task.
Created a new patch, with support for 'USB_DEVICE(0x0cf3, 0xe005)' and not the 'USB_DEVICE(0x0cf3, 0x3005)'

sha256sum='e0c100fe0949a86088537c37e2e0e585730ab625e923efa5993467b80264e68c'

I would remove the old one, if I knew how.

edit:Situation unchanged, just patched my ABS package to run 3.15.3-1.
Comment by João Paulo (leduck) - Tuesday, 01 July 2014, 16:46 GMT
Please apply this patch in the next version.
Comment by GI Jack (GI_Jack) - Thursday, 03 July 2014, 21:37 GMT
can confirm

running an a3thk card, and getting

ath3k: probe of 4-2:1.0 failed with error -110
Comment by Alessandro Rosetti (paradox) - Saturday, 05 July 2014, 09:42 GMT
3.15.3-1-ARCH same problem.

waiting for the patch...
Comment by GI Jack (GI_Jack) - Monday, 07 July 2014, 21:55 GMT
I can confirm the patch posted works with 3.15.3

edit: attached is PKGBUILD for linux with above patch added.

plz mainline
   PKGBUILD (11.9 KiB)
Comment by Marcel (hobbypunk) - Thursday, 10 July 2014, 08:03 GMT
same problem on 3.15.4 :(
Comment by João Paulo (leduck) - Friday, 11 July 2014, 17:08 GMT
Problem still on 3.15.5-1
Comment by Michael Bentlage (mib1982) - Friday, 11 July 2014, 19:02 GMT
I took the PKGBUILD from GI Jack and built my own 3.15.5-2 (the one which is currently in testing)
Bluetooth works with it.
The PKGBUILD with all neccessary patchfiles is attached in this post. (Only one of this patchfiles is needed for the Bluetooth-issue, though.)

I uploaded the Kernel to Wuala, if you don't want to compile yourself. You can download it via the following URL:
https://www.wuala.com/MiB1982/Archlinux/?key=KernelBTPatch
Comment by João Paulo (leduck) - Friday, 11 July 2014, 19:05 GMT
Okay, but why not apply this patch to the current kernel? Have released at least 3 versions after the release of this patch. The problem is that compiling a kernel only because of the patch, I have to do this every update. Is there any problem for him to have not been applied to the official kernel?
Comment by Michael Bentlage (mib1982) - Friday, 11 July 2014, 19:15 GMT
Frankly, I don't know and wonder the same thing. I am just another user who suffered from the bug, voted for it, and got annoyed that it wasn't applied to the kernel. So I took things in my own hands.

Edit: Upstream hasn't included the patch either, yet. I guess the Arch-Maintainers wait for that to happen.
Comment by Enzzo (souenzzo) - Saturday, 12 July 2014, 19:31 GMT
Same problem here.
I try to install linux-lts (3.14.12) and also not working.
Comment by João Paulo (leduck) - Friday, 18 July 2014, 19:10 GMT
Problem still on 3.15.5-2.
How long we have to wait to apply this patch in the kernel repository?
Comment by mark (qinohe) - Tuesday, 22 July 2014, 18:31 GMT
Problem is solved in 3.16rc6-mainline, this will probably hit stable soon, so I mark this task solved.
edit: I leave it open till it hit's stable.
Comment by Anatol Pomozov (anatolik) - Tuesday, 22 July 2014, 21:55 GMT
> How long we have to wait to apply this patch in the kernel repository?

Arch keeps packages close to upstream, it does not add patches not accepted by the project. Now when the patch is accepted it's OK to use it in arch package. But IMHO it is better to wait until it landed in linux-stable repo. Talk to Greg Hartman and ask to push the patch to linux-stable.
Comment by mark (qinohe) - Wednesday, 23 July 2014, 07:58 GMT
@Anatol, I asked that same qestion to Johan Hedberg, he said it would be in stable shortly after it was in mainline.
Next time I walk adifferent path when having a kernel bug, I put it on the mailinglist, not bugzilla!
Comment by GI Jack (GI_Jack) - Sunday, 27 July 2014, 19:39 GMT
>Arch keeps packages close to upstream, it does not add patches not accepted by the project

yes, but Arch makes exceptions for bugfixes, stability fixes, and coherency. Arch is not an "absolute vanilla" distro, but is very much OK with added patches for bugfixes.

to mib1982 and qinohe good job guys. My beef is that the community did the work, all that was needed was a review of the code, and simply re-using what was uploaded.
Comment by mark (qinohe) - Monday, 28 July 2014, 08:45 GMT
Thanks GI Jack, the community works ;-)
In the end I'm happy it happened. I learned how to make a patch, how to patch, install a kernel and make my own. I'm running abs/mainline tailored to my machine, without a glitch.
I say a big thank you all who contributed.
Comment by GI Jack (GI_Jack) - Thursday, 31 July 2014, 19:27 GMT
Its working in 3.15.7 unpatched. This bug may be closed.

Loading...