Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40877 - [linux] iwlwifi does not connect with Intel Dual Band Wireless-AC 7260

Attached to Project: Arch Linux
Opened by Tomi Leppänen (Tomin) - Tuesday, 17 June 2014, 16:22 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 13 August 2014, 07:36 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
I have Dell XPS 13 (9333) with Intel Dual Band Wireless-AC 7260 wifi card and I can't get it connecting to my wlan network. I've got my SSID and key correct but it still doesn't connect. wpa_supplicant output:
Successfully initialized wpa_supplicant
wlp2s0: CTRL-EVENT-SCAN-STARTED
wlp2s0: SME: Trying to authenticate with 74:ea:3a:ae:98:bf (SSID='Koti-WLAN' freq=2412 MHz)
wlp2s0: Trying to associate with 74:ea:3a:ae:98:bf (SSID='Koti-WLAN' freq=2412 MHz)
wlp2s0: Associated with 74:ea:3a:ae:98:bf
wlp2s0: WPA: Key negotiation completed with 74:ea:3a:ae:98:bf [PTK=CCMP GTK=TKIP]
wlp2s0: CTRL-EVENT-CONNECTED - Connection to 74:ea:3a:ae:98:bf completed [id=0 id_str=]
wlp2s0: CTRL-EVENT-DISCONNECTED bssid=74:ea:3a:ae:98:bf reason=4 locally_generated=1
wlp2s0: CTRL-EVENT-SCAN-STARTED
wlp2s0: SME: Trying to authenticate with 74:ea:3a:ae:98:bf (SSID='Koti-WLAN' freq=2412 MHz)
wlp2s0: Trying to associate with 74:ea:3a:ae:98:bf (SSID='Koti-WLAN' freq=2412 MHz)
wlp2s0: Associated with 74:ea:3a:ae:98:bf
wlp2s0: WPA: Key negotiation completed with 74:ea:3a:ae:98:bf [PTK=CCMP GTK=TKIP]
wlp2s0: CTRL-EVENT-CONNECTED - Connection to 74:ea:3a:ae:98:bf completed [id=0 id_str=]
wlp2s0: CTRL-EVENT-DISCONNECTED bssid=74:ea:3a:ae:98:bf reason=4 locally_generated=1
wlp2s0: CTRL-EVENT-SCAN-STARTED
wlp2s0: SME: Trying to authenticate with 74:ea:3a:ae:98:bf (SSID='Koti-WLAN' freq=2412 MHz)
wlp2s0: Trying to associate with 74:ea:3a:ae:98:bf (SSID='Koti-WLAN' freq=2412 MHz)
wlp2s0: Associated with 74:ea:3a:ae:98:bf
wlp2s0: WPA: Key negotiation completed with 74:ea:3a:ae:98:bf [PTK=CCMP GTK=TKIP]
wlp2s0: CTRL-EVENT-CONNECTED - Connection to 74:ea:3a:ae:98:bf completed [id=0 id_str=]
wlp2s0: CTRL-EVENT-DISCONNECTED bssid=74:ea:3a:ae:98:bf reason=4 locally_generated=1

Also dmesg listing (only relevant parts):
[ 1.260066] cfg80211: Calling CRDA to update world regulatory domain
[ 1.289057] iwlwifi 0000:02:00.0: irq 60 for MSI/MSI-X
[ 1.294923] iwlwifi 0000:02:00.0: loaded firmware version 23.214.9.0 op_mode iwlmvm
[ 1.340430] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0x144
[ 1.340588] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
[ 1.340850] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
[ 1.547386] systemd-udevd[156]: renamed network interface wlan0 to wlp2s0
[ 51.901990] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
[ 51.902254] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
[ 51.917391] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[ 69.356848] wlp2s0: authenticate with 74:ea:3a:ae:98:bf
[ 69.359911] wlp2s0: send auth to 74:ea:3a:ae:98:bf (try 1/3)
[ 69.361680] wlp2s0: authenticated
[ 69.366344] wlp2s0: associate with 74:ea:3a:ae:98:bf (try 1/3)
[ 69.369238] wlp2s0: RX AssocResp from 74:ea:3a:ae:98:bf (capab=0x431 status=0 aid=7)
[ 69.370013] wlp2s0: associated
[ 69.370055] IPv6: ADDRCONF(NETDEV_CHANGE): wlp2s0: link becomes ready
[ 69.666648] iwlwifi 0000:02:00.0: No association and the time event is over already...
[ 69.667817] wlp2s0: Connection to AP 74:ea:3a:ae:98:bf lost
[ 69.709602] cfg80211: Calling CRDA to update world regulatory domain
[ 73.406412] wlp2s0: authenticate with 74:ea:3a:ae:98:bf
[ 73.408957] wlp2s0: send auth to 74:ea:3a:ae:98:bf (try 1/3)
[ 73.410758] wlp2s0: authenticated
[ 73.414104] wlp2s0: associate with 74:ea:3a:ae:98:bf (try 1/3)
[ 73.417048] wlp2s0: RX AssocResp from 74:ea:3a:ae:98:bf (capab=0x431 status=0 aid=7)
[ 73.417665] wlp2s0: associated
[ 73.715618] iwlwifi 0000:02:00.0: No association and the time event is over already...
[ 73.716906] wlp2s0: Connection to AP 74:ea:3a:ae:98:bf lost
[ 73.787285] cfg80211: Calling CRDA to update world regulatory domain
[ 77.474460] wlp2s0: authenticate with 74:ea:3a:ae:98:bf
[ 77.476970] wlp2s0: send auth to 74:ea:3a:ae:98:bf (try 1/3)
[ 77.478770] wlp2s0: authenticated
[ 77.485171] wlp2s0: associate with 74:ea:3a:ae:98:bf (try 1/3)
[ 77.488132] wlp2s0: RX AssocResp from 74:ea:3a:ae:98:bf (capab=0x431 status=0 aid=7)
[ 77.488872] wlp2s0: associated
[ 77.783643] iwlwifi 0000:02:00.0: No association and the time event is over already...
[ 77.785125] wlp2s0: Connection to AP 74:ea:3a:ae:98:bf lost
[ 77.851714] cfg80211: Calling CRDA to update world regulatory domain
[ 81.542056] wlp2s0: authenticate with 74:ea:3a:ae:98:bf
[ 81.544612] wlp2s0: send auth to 74:ea:3a:ae:98:bf (try 1/3)
[ 81.546619] wlp2s0: authenticated
[ 81.552844] wlp2s0: associate with 74:ea:3a:ae:98:bf (try 1/3)
[ 81.555688] wlp2s0: RX AssocResp from 74:ea:3a:ae:98:bf (capab=0x431 status=0 aid=7)
[ 81.556427] wlp2s0: associated
[ 81.851292] iwlwifi 0000:02:00.0: No association and the time event is over already...
[ 81.852899] wlp2s0: Connection to AP 74:ea:3a:ae:98:bf lost
[ 81.916052] cfg80211: Calling CRDA to update world regulatory domain
[ 103.592216] wlp2s0: authenticate with 74:ea:3a:ae:98:bf
[ 103.594851] wlp2s0: send auth to 74:ea:3a:ae:98:bf (try 1/3)
[ 103.596707] wlp2s0: authenticated
[ 103.600573] wlp2s0: associate with 74:ea:3a:ae:98:bf (try 1/3)
[ 103.603508] wlp2s0: RX AssocResp from 74:ea:3a:ae:98:bf (capab=0x431 status=0 aid=7)
[ 103.604750] wlp2s0: associated
[ 103.901518] iwlwifi 0000:02:00.0: No association and the time event is over already...
[ 103.903472] wlp2s0: Connection to AP 74:ea:3a:ae:98:bf lost
[ 103.943876] cfg80211: Calling CRDA to update world regulatory domain
[ 122.178524] wlp2s0: authenticate with 74:ea:3a:ae:98:bf
[ 122.181195] wlp2s0: send auth to 74:ea:3a:ae:98:bf (try 1/3)
[ 122.183063] wlp2s0: authenticated
[ 122.183692] wlp2s0: associate with 74:ea:3a:ae:98:bf (try 1/3)
[ 122.186638] wlp2s0: RX AssocResp from 74:ea:3a:ae:98:bf (capab=0x431 status=0 aid=7)
[ 122.187643] wlp2s0: associated
[ 122.487873] iwlwifi 0000:02:00.0: No association and the time event is over already...
[ 122.490688] wlp2s0: Connection to AP 74:ea:3a:ae:98:bf lost
[ 122.573516] cfg80211: Calling CRDA to update world regulatory domain
[ 126.246763] wlp2s0: authenticate with 74:ea:3a:ae:98:bf
[ 126.249297] wlp2s0: send auth to 74:ea:3a:ae:98:bf (try 1/3)
[ 126.251151] wlp2s0: authenticated
[ 126.251371] wlp2s0: associate with 74:ea:3a:ae:98:bf (try 1/3)
[ 126.254261] wlp2s0: RX AssocResp from 74:ea:3a:ae:98:bf (capab=0x431 status=0 aid=7)
[ 126.255016] wlp2s0: associated
[ 126.555958] iwlwifi 0000:02:00.0: No association and the time event is over already...
[ 126.557907] wlp2s0: Connection to AP 74:ea:3a:ae:98:bf lost
[ 126.611321] cfg80211: Calling CRDA to update world regulatory domain
[ 130.309723] wlp2s0: authenticate with 74:ea:3a:ae:98:bf
[ 130.312389] wlp2s0: send auth to 74:ea:3a:ae:98:bf (try 1/3)
[ 130.314145] wlp2s0: authenticated
[ 130.315849] wlp2s0: associate with 74:ea:3a:ae:98:bf (try 1/3)
[ 130.318822] wlp2s0: RX AssocResp from 74:ea:3a:ae:98:bf (capab=0x431 status=0 aid=7)
[ 130.319746] wlp2s0: associated
[ 130.619134] iwlwifi 0000:02:00.0: No association and the time event is over already...
[ 130.621907] wlp2s0: Connection to AP 74:ea:3a:ae:98:bf lost
[ 130.675711] cfg80211: Calling CRDA to update world regulatory domain
[ 134.374239] wlp2s0: authenticate with 74:ea:3a:ae:98:bf
[ 134.376968] wlp2s0: send auth to 74:ea:3a:ae:98:bf (try 1/3)
[ 134.378778] wlp2s0: authenticated
[ 134.380219] wlp2s0: associate with 74:ea:3a:ae:98:bf (try 1/3)
[ 134.383172] wlp2s0: RX AssocResp from 74:ea:3a:ae:98:bf (capab=0x431 status=0 aid=7)
[ 134.383956] wlp2s0: associated
[ 134.683651] iwlwifi 0000:02:00.0: No association and the time event is over already...
[ 134.687460] wlp2s0: Connection to AP 74:ea:3a:ae:98:bf lost
[ 134.740101] cfg80211: Calling CRDA to update world regulatory domain
[ 138.438946] wlp2s0: authenticate with 74:ea:3a:ae:98:bf
[ 138.441641] wlp2s0: send auth to 74:ea:3a:ae:98:bf (try 1/3)
[ 138.443493] wlp2s0: authenticated
[ 138.444678] wlp2s0: associate with 74:ea:3a:ae:98:bf (try 1/3)
[ 138.447643] wlp2s0: RX AssocResp from 74:ea:3a:ae:98:bf (capab=0x431 status=0 aid=7)
[ 138.448629] wlp2s0: associated
[ 138.748384] iwlwifi 0000:02:00.0: No association and the time event is over already...
[ 138.750279] wlp2s0: Connection to AP 74:ea:3a:ae:98:bf lost
[ 138.791230] cfg80211: Calling CRDA to update world regulatory domain
[ 142.489705] wlp2s0: authenticate with 74:ea:3a:ae:98:bf
[ 142.492440] wlp2s0: send auth to 74:ea:3a:ae:98:bf (try 1/3)
[ 142.494206] wlp2s0: authenticated
[ 142.495781] wlp2s0: associate with 74:ea:3a:ae:98:bf (try 1/3)
[ 142.498669] wlp2s0: RX AssocResp from 74:ea:3a:ae:98:bf (capab=0x431 status=0 aid=7)
[ 142.499508] wlp2s0: associated
[ 142.799148] iwlwifi 0000:02:00.0: No association and the time event is over already...
[ 142.802925] wlp2s0: Connection to AP 74:ea:3a:ae:98:bf lost
[ 142.882277] cfg80211: Calling CRDA to update world regulatory domain
[ 146.556233] wlp2s0: authenticate with 74:ea:3a:ae:98:bf
[ 146.558882] wlp2s0: send auth to 74:ea:3a:ae:98:bf (try 1/3)
[ 146.560748] wlp2s0: authenticated
[ 146.563501] wlp2s0: associate with 74:ea:3a:ae:98:bf (try 1/3)
[ 146.566499] wlp2s0: RX AssocResp from 74:ea:3a:ae:98:bf (capab=0x431 status=0 aid=7)
[ 146.567307] wlp2s0: associated
[ 146.865568] iwlwifi 0000:02:00.0: No association and the time event is over already...
[ 146.869328] wlp2s0: Connection to AP 74:ea:3a:ae:98:bf lost
[ 146.933355] cfg80211: Calling CRDA to update world regulatory domain

Those "No association and the time event is over already" messages print to tty when trying to connect. I have tried 11n_disabled=1 option but it doesn't do a thing.


Additional info:
* package version(s)
- tried with linux 3.14.6-1 and 3.15.1-1 (listings are with 3.15)
- linux-firmware version I can't remember but I upgraded it from testing, but neither worked
- all packages x86_64
* config and/or log files etc.
- Router had 802.11n and WPA2 security

Steps to reproduce:
Use a Intel Dual Band Wireless-AC 7260 wlan card and a wifi router (I used a cheap TP-Link n-wifi router, can't remember the model right now and I'm not at home right now but later this week). Try to connect the wifi network.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 13 August 2014, 07:36 GMT
Reason for closing:  Fixed
Comment by Tomi Leppänen (Tomin) - Thursday, 19 June 2014, 14:58 GMT
The AP is TP-Link's TP-WA801ND and it doesn't actually have a router (it's just an AP). Today I upgraded linux to 3.15.1-1 and it still doesn't work (probably no reason for any change anyway) and linux-firmware is version 20140603.a4f3bc0-1.
Comment by Tomi Leppänen (Tomin) - Saturday, 21 June 2014, 05:12 GMT
I was able to connect to my grandparent's wifi network. linux 3.15.1-1 and linux-firmware 20140603.a4f3bc0-1.
Comment by Tomi Leppänen (Tomin) - Saturday, 21 June 2014, 10:31 GMT
Today I tried connecting to my wifi network and it worked just fine. I used Network Manager but that shouldn't make any difference (and it didn't work yesterday). I don't think I've upgraded anything critical. I will tell if it stops working again.
Comment by Chris Berkhout (chrisberkhout) - Wednesday, 25 June 2014, 20:33 GMT
I'm having the same issue, with an up to date system, in a cafe (so sorry, no more details about the AP).
Comment by Tomi Leppänen (Tomin) - Tuesday, 01 July 2014, 14:23 GMT
I haven't had this problem for over a week now. I think I've rebooted my router after reporting this and when I got wifi working. Yesterday I had quite slow connection for some reason though, but I can't be sure it was because of the wifi. I'll do some more testing later but I guess this bug is closed if I'm concerned.

Loading...