Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40785 - [rdesktop] Version 1.8.2 Serious BUG

Attached to Project: Community Packages
Opened by init (anti_user) - Tuesday, 10 June 2014, 16:11 GMT
Last edited by Balló György (City-busz) - Sunday, 17 March 2019, 17:39 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jelle van der Waa (jelly)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

I cannot connect to Windows Server 2008 anymore with this version of rdesktop. On earalier versions its work good.
Connection to Windows Server 2003 work okay with this version. If i downgrade to oldest version everything work.
Im even to remove directory ~/.rdesktop and then do connect to 2008 server, directory doesnt create, and not connecting too with error.

Additional info:
* rdesktop-1.8.2-1-x86_64.pkg.tar.xz
* Autoselected keyboard map ru
ERROR: CredSSP: Initialize failed, do you have correct kerberos tgt initialized ?
Connection established using SSL.
disconnect: Invalid licensing message.



Steps to reproduce:
do a usual connection w/o any flags rdesktop HOST
This task depends upon

Closed by  Balló György (City-busz)
Sunday, 17 March 2019, 17:39 GMT
Reason for closing:  Upstream
Comment by init (anti_user) - Tuesday, 10 June 2014, 16:14 GMT
im trying to connect to different 2008 servers (count of two).
trying to connect from two different client workstations (with updated ArchLinux to latest date)
Comment by Jelle van der Waa (jelly) - Tuesday, 10 June 2014, 19:43 GMT
Seems to be a problem with SSL certs, since rdesktop works fine for me.
Comment by init (anti_user) - Wednesday, 11 June 2014, 01:10 GMT
there is no issue with ssl certs, because earlier versions of rdesktop works good
Comment by Martin (Jorval) - Thursday, 03 July 2014, 09:41 GMT
Have the same Problems since update to 1.8.2 on Manjaro 64bit.
Trying W2008R2 TS end up in the CredSSP Error.
W2K3 TS Server working fine.

downgrade to 1.8.1 fixed it also for me.
There's definate something with the 1.8.2 release.
Comment by Doug Newgard (Scimmia) - Monday, 06 July 2015, 21:32 GMT
Status with 1.8.3?
Comment by Simone Lazzaris (ziopera) - Friday, 11 December 2015, 15:22 GMT
  • Field changed: Percent Complete (100% → 0%)
I'm using 1.8.3 and have the same issue. krdc works fine
Comment by Thomas Kuschel (oe1tkt) - Sunday, 13 December 2015, 12:57 GMT
Same with 1.8.3 and Windows Server 2008 R2 ServicePack 1, also the same problem with (x)freerdp, switched to Remmina Remote Desktop Client (works excellent).
Comment by Jelle van der Waa (jelly) - Saturday, 26 March 2016, 19:58 GMT
Please report this issue upstream.

Loading...