Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40751 - [webkitgtk2] Messed up dependencies

Attached to Project: Arch Linux
Opened by Philipp (hollunder) - Saturday, 07 June 2014, 19:41 GMT
Last edited by Jan Alexander Steffens (heftig) - Saturday, 07 June 2014, 21:05 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Hi there.
The dependencies of webkitgtk2 are seriously messed up, at least since the addition of geoclue2.
This thing, wahtever it does, depends on networkmanager, which in turn depends on a whole lot of other crap that has absolutely nothing to do with a browser or rendering engine.

Seriously, it's nice that you want to add features, but please keep the dependencies sane.

Additional info:
* package version(s)
2.4.3-1
* config and/or log files etc.
This is what my update looked like, at least half of this is not currently installed on my system:
Packages (12): geoclue2-2.1.8-1 hunspell-1.3.3-1 js17-17.0.0-1 json-glib-1.0.2-1 libevdev-1.2.2-1 libice-1.0.9-1
libmm-glib-1.2.0-3 libxft-2.3.2-1 networkmanager-0.9.8.10-1 polkit-0.112-2 sqlite-3.8.5-1
webkitgtk2-2.4.3-1

This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Saturday, 07 June 2014, 21:05 GMT
Reason for closing:  Fixed
Comment by Jan Alexander Steffens (heftig) - Saturday, 07 June 2014, 20:25 GMT
Gonna split libnm from networkmanager and have geoclue2 depend on that.

Loading...