Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40692 - [perl-tk] Needs rebuild for perl 5.20.0.

Attached to Project: Arch Linux
Opened by Brian BIdulock (bidulock) - Wednesday, 04 June 2014, 21:35 GMT
Last edited by Felix Yan (felixonmars) - Monday, 07 July 2014, 14:33 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

perl-tk requires rebuild against perl-5.20.0.
This task depends upon

Closed by  Felix Yan (felixonmars)
Monday, 07 July 2014, 14:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  804.032-3
Comment by Doug Newgard (Scimmia) - Thursday, 05 June 2014, 02:53 GMT
Version numbers, please! 804.032-2 says it was rebuilt for Perl 5.20, is it not?
Comment by Rick Klement (tybalt89) - Thursday, 05 June 2014, 16:17 GMT
perl-tk fails on i686

versions:
perl 5.20.0-2
perl-tk 804.032-2

test program - perl -MTk -e '$mw = new MainWindow'
Comment by Felix Yan (felixonmars) - Friday, 06 June 2014, 03:50 GMT
It had been rebuilt, and rebuild again doesn't solve anything.

Looks like an upstream issue then :/
Comment by Brian BIdulock (bidulock) - Friday, 06 June 2014, 13:16 GMT
Yes, the problem appears to be deep in Tk. I looked but
I'm no perl XS expert...

I reported the following upstream bug:

https://rt.cpan.org/Public/Bug/Display.html?id=96280
Comment by Brian BIdulock (bidulock) - Saturday, 07 June 2014, 17:12 GMT
New developments:

I made a perl-tk-git package at

https://aur.archlinux.org/packages/perl-tk-git/

and it runs fine.


It appears to be this upstream commit that solved the problem:

https://github.com/eserte/perl-tk/commit/ba3a92a779f7adcf655b7e45b40ee5b0cb79bc8b

I have attached the diff as a patch that could be applied until
the upstream changes make it into a release.

Comment by Felix Yan (felixonmars) - Saturday, 07 June 2014, 17:35 GMT
I've already tried to use that commit as a patch, but sadly that doesn't solve the crash for me.

Here's a package for x86_64 as well as the source package, if you want to take a look.
http://pkgbuild.com/~fyan/staging/perl-tk-804.032-3-x86_64.pkg.tar.xz
http://pkgbuild.com/~fyan/staging/perl-tk-804.032-3.src.tar.gz
Comment by Brian BIdulock (bidulock) - Saturday, 07 June 2014, 18:05 GMT
Well, must be one of the other commits then...

Try https://aur.archlinux.org/packages/perl-tk-git/

this works fine for me.

Attached is a patch that patches in all of the commits up to the current git.
Comment by Brian BIdulock (bidulock) - Saturday, 07 June 2014, 18:23 GMT
I tried your PKGBUILD and it segfaults for me too...

Comment by Glenn (grepfor) - Sunday, 22 June 2014, 16:15 GMT
Fwiw:

1. Confirm problem with extra/perl-tk-804.032-2 under perl 5.20.0-4.
2. Git version from AUR (perl-tk-git-804.032.r8.g2eaf2e3-2-i686) seems to work OK.

Both observations above on a system that was -Syyu'ed on 21-Jun-2014 around 22:00 UTC.
Comment by Felix Yan (felixonmars) - Sunday, 22 June 2014, 16:17 GMT
Thanks, I'll take time to figure out the exact commit to patch.
Comment by Brian BIdulock (bidulock) - Sunday, 22 June 2014, 18:03 GMT
The latest perl 5.20.0-5 fixes some issues with language, which might be related. Should try the old package with the new perl first.
Comment by Glenn (grepfor) - Saturday, 05 July 2014, 23:36 GMT
Just checked extra/perl-tk-804.032-2 under perl 5.20.0-5, still seeing segfault.
Comment by Brian BIdulock (bidulock) - Sunday, 06 July 2014, 01:30 GMT
Judging from this bug report, near the bottom:

https://rt.cpan.org/Public/Bug/Display.html?id=96543

It appears that both the TkMainWindow create commit and the freetype.h header file commits are needed to do the job. That is likely why perl-tk-git works but not the TkMainWindow create commit applied on its own to 804.302. We should likely just apply the git.patch file above and wait for the next release.
Comment by Felix Yan (felixonmars) - Monday, 07 July 2014, 05:47 GMT
  • Field changed: Status (Assigned → Requires Testing)
perl-tk 804.032-3 has been uploaded to [extra], with one more commit that fixes the segfault here for me. Please let me know if it works for you as well.
Comment by Glenn (grepfor) - Monday, 07 July 2014, 12:34 GMT
No longer seeing the segfault here with 804.032-3 against perl 5.20.0-5.

Thanks for your work on it guys, much appreciated.
Comment by Rick Klement (tybalt89) - Monday, 07 July 2014, 14:25 GMT
perl-tk 804.032-3 works for me with perl 5.20.0-5

Thanks.
Comment by Glenn (grepfor) - Monday, 07 July 2014, 14:29 GMT

Loading...