Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40677 - [hostapd] install sample configs under /usr/share/doc/ instead of /etc/

Attached to Project: Community Packages
Opened by Jakub Klinkovsk√Ĺ (lahwaacz) - Wednesday, 04 June 2014, 08:40 GMT
Last edited by Sergej Pupykin (sergej) - Wednesday, 04 June 2014, 11:53 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

All the files under /etc/hostapd/ are just "example documentation configs" which are not suitable for production use. It is much more convenient to install them under /usr/share/doc/hostapd/ for the following reasons:

* Everybody using hostapd will have to modify the current configs in /etc/hostapd/. Users will hardly overwrite files in /usr/share/doc/ so keeping "example documentation configs" there will ease maintenance of short and much clearer separate config files.
* The decision to keep the configs under /etc/ is made in PKGBUILD [1], there is no indication from upstream that the files belong to /etc/ (Debian also installs them under /usr/share/doc/ [2]).
* Keeping "example documentation configs" with uncommented options might lead to unintended behaviour. Starting a service (hostapd.service in this case) before any changes to the default configuration are made should either work out-of-the-box or fail due to missing/faulty configuration.

For further reasoning please see https://mailman.archlinux.org/pipermail/arch-general/2014-May/036386.html

[1]: https://projects.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/hostapd#n55
[2]: https://packages.debian.org/wheezy/amd64/hostapd/filelist
This task depends upon

Closed by  Sergej Pupykin (sergej)
Wednesday, 04 June 2014, 11:53 GMT
Reason for closing:  Fixed

Loading...