Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40676 - [chromium] re-enable NPAPI support

Attached to Project: Arch Linux
Opened by Balder Lingegård (cellisten) - Wednesday, 04 June 2014, 07:49 GMT
Last edited by Dave Reisner (falconindy) - Saturday, 07 June 2014, 16:59 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: From version 35 Google has dropped NPAPI support. This causes several plugins, among them pipelight (used to get silverlight, widevine etc. to work), to stop working. The NPAPI support is only dropped in linux for now which makes the linux version feature incomplete. I realize that pipelight is not part of the package database but NPAPI support is larger than that.


Additional info:
* Present in version 35+ of chromium
* NPAPI plugin needs to be used, for example pipelight.


Steps to reproduce:
* Install pipelight
* Enable silverlight (pipelight-plugin --enable silverlight)
* Go to http://bubblemark.com/sl3/TestPage.html and test, will not work in 35, will work in 34.

Proposed fix:
Michael Müller of pipelight has already proposed patches to chromium to re-enable the NPAPI plugins at https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1307989.
Patches are attached.
The fix causes the content to be played in a separate window as embed is not supported. Pipelight version >= 0.2.6 is required to make this work.
This task depends upon

Closed by  Dave Reisner (falconindy)
Saturday, 07 June 2014, 16:59 GMT
Reason for closing:  Won't implement
Additional comments about closing:  upstream decision, and it's not Arch's place to change it
Comment by Jan de Groot (JGC) - Wednesday, 04 June 2014, 08:44 GMT
The patch doesn't implement NPAPI completely, it only enables loading the plugins, anything besides that fails and only plugins detecting that (pipelight) will work with the patched version.

I don't think this should be added. And besides that, removing NPAPI is an upstream choice. We shouldn't bring back an API that was removed upstream.
Comment by Balder Lingegård (cellisten) - Wednesday, 04 June 2014, 08:51 GMT
Reasonable comment. I wasn't aware to what extent the patches would help any other plugin but pipelight does give support to a range of plugins. Regarding removing NPAPI upstream, the problem with that argument is that it's only been removed on Linux so far. If this bug is closed as won't fix, I guess I'll have to look into doing a chromium-pipelight AUR pkgbuild and compile from source with the patches or simply switch to firefox.
I think there is a value in supporting Silverlight, Widevine etc. on Linux and without this patch that will be impossible until the pipelight team find another way. Maybe we could add the patches until a new solution is implemented from the pipelight team? What would your suggested solution be to get for example silverlight support in chromium on Linux? Just not bother?
Comment by Jan de Groot (JGC) - Wednesday, 04 June 2014, 11:08 GMT
NPAPI is deprecated and marked for removal. They want to remove it from all platforms before the end of this year. Reason why linux doesn't include NPAPI anymore is because they didn't want to spend time on porting NPAPI to the new Aura toolkit.

https://groups.google.com/a/chromium.org/forum/#!topic/chromium-dev/xEbgvWE7wMk
Comment by Balder Lingegård (cellisten) - Wednesday, 04 June 2014, 11:32 GMT
I am aware of the situation. My point is that the only way of running Silverlight and Widevine currently is using pipelight. For users who need it to use services they pay for (Netflix, HBO and so on) it is a very noticeable change, albeit not a regression as it's a planned change.
Dropping NPAPI will be worse for Linux than Windows when it comes to these plugins as it's very hard to wrap a wine sandbox in a PPAPI, as discussed in the pipelight bug I linked.

But the simple question I would like an answer to is this:
What do you think is the best way to proceed if you as a user do need to use these plugins. Should that user simply change to Firefox?

I personally don't think it's a very big problem as I've found the root cause. In my case, I can downgrade chromium, use another browser or simply recompile chromium with the patches. For a lot of users, this won't be the case. Maybe an announcement would be in order so users who use these plugins can see that to upgrade will break them? I think it is exactly the type of problem that Arch users expect to be informed about when they follow the guideline in the wiki to know if any user intervention is needed. Wouldn't you agree?


Comment by Jan de Groot (JGC) - Wednesday, 04 June 2014, 14:35 GMT
If you want NPAPI, change to firefox. My guess is that other Webkit browsers will kill NPAPI support too in the near future.
Comment by Balder Lingegård (cellisten) - Wednesday, 04 June 2014, 14:38 GMT
OK, good to know. Do you happen to know who to contact to get a news announcement? As this breaks without any sort of feedback to the user or from Pacman I believe that it would be good to have an announcement.

Loading...