Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40661 - [wpa_supplicant] install sample config under /usr/share/doc/ instead of /etc/

Attached to Project: Arch Linux
Opened by Jakub Klinkovský (lahwaacz) - Tuesday, 03 June 2014, 16:22 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Friday, 09 December 2016, 21:32 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 16
Private No

Details

The default /etc/wpa_supplicant/wpa_supplicant.conf is an "example documentation config" with uncommented options and, more importantly, also multiple network blocks uncommented. Keeping it under /etc/ might lead to unintended behaviour. For example, in conjunction with the recently introduced dhcpcd hook [1], it may lead to wpa_supplicant being started without user's intervention and not failing due to the network blocks uncommented in wpa_supplicant.conf.

As the decision to keep the configs under /etc/ is made in PKGBUILD [2], I think it is sane to install it under /usr/share/doc/ instead. Even wpa_supplicant.conf(5) indicates that the path to example config is "probably" /usr/share/doc/wpa_supplicant/.

For further reasoning please see https://mailman.archlinux.org/pipermail/arch-general/2014-May/036386.html

[1]: https://wiki.archlinux.org/index.php/Dhcpcd#10-wpa_supplicant
[2]: https://projects.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/wpa_supplicant#n42
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Friday, 09 December 2016, 21:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  wpa_supplicant 1:2.6-3
Comment by cupcake (muffins) - Friday, 25 July 2014, 01:45 GMT
Please do this. Not only does the upstream documentation indicate the location, but also the file itself is stamped everywhere with "example" making it pretty clear it's not meant to be a default config.
Comment by Yamakaky (Yamakaky) - Wednesday, 10 September 2014, 20:18 GMT
+1. wpa_gui updates the config with new networks so all the comments are lost.
Comment by Earnestly (Earnest) - Monday, 22 September 2014, 21:20 GMT
This default setting also causes many headaches when helping users with wpa_supplicant and causes additional issues because they don't realise it's designed as documentation.
Comment by holos (holomorph) - Monday, 22 September 2014, 21:24 GMT Comment by Jakub Klinkovský (lahwaacz) - Wednesday, 08 October 2014, 14:57 GMT
As per [3], the default /etc/wpa_supplicant/wpa_supplicant.conf with "dummy values" may result in "boot-time parse errors" when using netctl-auto.

[3]: https://wiki.archlinux.org/index.php?title=Dhcpcd&diff=next&oldid=335969
Comment by Earnestly (Earnest) - Thursday, 23 July 2015, 22:02 GMT
Any progression on this? It still remains to be problematic when unsuspecting users think to use it.
Comment by mattia (nTia89) - Saturday, 21 May 2016, 13:33 GMT
man wpa_supplicat.conf says:

...
See the example configuration file, probably in /usr/share/doc/wpa_supplicant/, for detailed information
...

apart from this, files under /etc are configuration files, used by the user to modify the programs behaviour
and this makes think me that /etc/wpa_supplicant/wpa_supplicant.conf is a configuration file, not an example

IMHO /etc/wpa_supplicant/wpa_supplicant.conf should be moved in /usr/share/doc/wpa_supplicant/
Comment by Tinu Weber (ayekat) - Thursday, 08 December 2016, 19:40 GMT
Since the last suggested patch has gone 404, here is another one for the current version (2.6-2).
Comment by Bartłomiej Piotrowski (Barthalion) - Thursday, 08 December 2016, 20:07 GMT
Don't worry, I have it prepared locally since some time. The change requires some more coordination though, stay tuned.
Comment by Tinu Weber (ayekat) - Thursday, 08 December 2016, 20:29 GMT
Ah, OK, I'm sorry.
But thanks for the feedback!

Loading...