Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40622 - [libreoffice-impress] Missing dependency on avahi

Attached to Project: Arch Linux
Opened by Steven Honeyman (stevenhoneyman) - Saturday, 31 May 2014, 11:07 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 31 May 2014, 12:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

On a new Arch linux install (without avahi), "libreoffice impress" starts to load and then closes. Run from a command line, it gives an error showing it's missing avahi libraries.
Installing avahi fixes this, but I'm not sure why it needs avahi! Possibly change from "--enable-avahi" to "--disable-avahi" in the PKGBUILD?

Also, the other parts of libreoffice all start OK even without avahi. Only Impress is affected by it not being there.

Steps to reproduce:

$ loimpress
Warning: failed to read path from javaldx
/usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libavahi-common.so.3: cannot open shared object file: No such file or directory

This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 31 May 2014, 12:11 GMT
Reason for closing:  Not a bug
Comment by Andreas Radke (AndyRTR) - Saturday, 31 May 2014, 12:10 GMT
libreoffice depends on libcups that depends on avahi. so your system is broken.

Loading...