Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#40592 - [chromium] ignores X keyboard layout, forces en-US

Attached to Project: Arch Linux
Opened by Johan Forberg (jforberg) - Wednesday, 28 May 2014, 23:07 GMT
Last edited by Evangelos Foutras (foutrelis) - Monday, 28 July 2014, 09:36 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



The current version of Chromium is broken as since about v. 35 it does not respect the keyboard layout given by X, but instead forces en-US layout.

The same error occurs for me in v. 36 (google-chrome-beta) and is reported also in v. 37. No other app has the error so it is clearly an issue with Chromium.

It's remarkable that such a crippling bug can be present in three major versions simultaneously.

This problem has been noted upstream:

Steps to reproduce:

1. Install chromium 35.1916 etc.
2. Change to non-US layout
3. Attempt to enter any non US-ASCII letter
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Monday, 28 July 2014, 09:36 GMT
Reason for closing:  None
Additional comments about closing:  Issue goes away after setting correct locale.
Comment by Evangelos Foutras (foutrelis) - Friday, 13 June 2014, 14:56 GMT
Does the following package solve this issue?

It includes the patch referenced in the upstream bug report:
Comment by Romain Riviere (Le_Coyote) - Monday, 23 June 2014, 14:08 GMT
Unfortunately, it does not.

Also, I believe a more accurate description of the problem is that non-ASCII characters are badly handled by Chromium. It has little to do with the keyboard layout.

In this instance, I'm using an azerty layout, and my "a" key sends an "a" character to Chromium, not a "q" if there was a layout mishap. However, my "é" sends a "2" and my "è" a "7", whereas "&" produces the expected "&" (it would produce a "1" if I were usong an en_US layout). Moreover, Level3 keystrokes are altered too.
Comment by Evangelos Foutras (foutrelis) - Monday, 23 June 2014, 20:16 GMT Comment by Romain Riviere (Le_Coyote) - Wednesday, 25 June 2014, 22:05 GMT
It does not fix the issue. Instead, accented characters such as "é" are simply ignored instead of being replaced by "2" as in other 35.0.x versions.
Comment by Romain Riviere (Le_Coyote) - Monday, 28 July 2014, 09:04 GMT
Apparently my locale setting was wrong: see
Thanks for pointing me in the right direction.

[Edit]The LC_CTYPE setting is apparently the one that matters.[/Edit]
Comment by Evangelos Foutras (foutrelis) - Monday, 28 July 2014, 09:30 GMT
Glad you figured it out.

I'll go ahead and close this.