Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40586 - [transmission-qt] fails to start

Attached to Project: Arch Linux
Opened by Morgan (superfaker123) - Wednesday, 28 May 2014, 15:43 GMT
Last edited by Anatol Pomozov (anatolik) - Thursday, 29 May 2014, 02:07 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Anatol Pomozov (anatolik)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

after updating to 2.83-2 transmission-qt fails to start with following message

[morgan@viral ~]$ transmission-qt
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: eglfs, kms, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
Aborted (core dumped)



I believe it's just missing libxkbcommon-x11 dependency
This task depends upon

Closed by  Anatol Pomozov (anatolik)
Thursday, 29 May 2014, 02:07 GMT
Reason for closing:  Fixed
Additional comments about closing:  Missing dependency added in 2.83-3
Comment by Doug Newgard (Scimmia) - Wednesday, 28 May 2014, 15:57 GMT
"I believe it's just missing libxkbcommon-x11 dependency" ... Which is already an optdep of qt5-base.
Comment by Andrea Scarpino (BaSh) - Wednesday, 28 May 2014, 17:15 GMT
Yes, it's missing it as dependence.
Comment by Anatol Pomozov (anatolik) - Wednesday, 28 May 2014, 22:09 GMT
The problem should be fixed in 2.83-3 that is currently propagated to [testing].
Comment by Morgan (superfaker123) - Thursday, 29 May 2014, 00:15 GMT
working! thanks!

Loading...