Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40495 - [virtualbox-guest-modules] [virtualbox-host-modules] Unable to load modules

Attached to Project: Community Packages
Opened by Jefferson Felix (jeffersonsfelix) - Thursday, 22 May 2014, 18:31 GMT
Last edited by Sébastien Luttringer (seblu) - Sunday, 14 December 2014, 01:11 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sébastien Luttringer (seblu)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description: The modules can't load with modprobe -a.
Using insmod, vboxguest and vboxsf loads, but when I try to load vboxvideo I get the message: Unknow symbol in module.

Additional info:
virtualbox-guest-modules-4.3.12-1
Virtual Box 4.3.12 (Windows XP Host)
Guest: Linux Linux-PC 3.14.4-1-ARCH

Steps to reproduce:
sudo modprobe -a vboxguest vboxsf vboxvideo
This task depends upon

Closed by  Sébastien Luttringer (seblu)
Sunday, 14 December 2014, 01:11 GMT
Reason for closing:  Fixed
Comment by Doug Newgard (Scimmia) - Friday, 23 May 2014, 03:45 GMT
depmod should have been run by the install script. If it didn't, there may be a bug here, but I'm not sure what.
Comment by Doug Newgard (Scimmia) - Saturday, 24 May 2014, 14:45 GMT
  • Field changed: Severity (Low → Medium)
There are multiple reports of this on the forum, it appears that depmod isn't being run in the install script.
Comment by Jake C. (f3rr37) - Thursday, 29 May 2014, 22:13 GMT
Reproduced on a Win8 host with Arch guest.
Comment by Ollie Armstrong (oarmstrong) - Sunday, 01 June 2014, 12:13 GMT
Also reproduced on Windows 7 host and Arch host both with Arch guests. Fixed it with:

# depmod

Before attempting to `# modprobe` the modules or load them on boot with `/etc/modules-load.d/*.conf`.
Comment by Doug Newgard (Scimmia) - Saturday, 19 July 2014, 18:30 GMT
  • Field changed: Summary ([virtualbox-guest-modules] Unable to load modules → [virtualbox-guest-modules] [virtualbox-guest-modules] Unable to load modules)
Have had a couple of reports on the forums of this happening with the host modules, too.
Comment by Sunjay Dhama (tFyeHXaqFdJNSwktzjb) - Monday, 21 July 2014, 01:40 GMT
I can confirm this bug with virtualbox-guest-modules-4.3.12. I reproduced it on Windows 7 vm. Unfortunately, was not able to fix with: # depmod
I get the following blue screen in windows 7 when I plug in an iPhone that previously had no problems before updating the virtualbox-guest-modules.
Things I have already tried can be found here > https://bbs.archlinux.org/search.php?action=show_user_posts&user_id=77279
Comment by Sébastien Luttringer (seblu) - Monday, 21 July 2014, 01:55 GMT
To avoid issue with these packages, I suggest you to use virtualbox-guest-dkms and virtualbox-host-dkms instead.
Comment by Sunjay Dhama (tFyeHXaqFdJNSwktzjb) - Monday, 21 July 2014, 02:15 GMT
Thank you Sebastien. Using virtualbox-guest-dkms and virtualbox-host-dkms instead fixed my issue.
Comment by Ole Ernst (olebowle) - Monday, 13 October 2014, 13:49 GMT
I don't know if it helps but I had a look through my cached virtualbox-host-modules packages. Turns out the reason depmod is not executed is that the .INSTALL file is missing in some of the packages.

virtualbox-host-modules-4.3.14-5 ok
virtualbox-host-modules-4.3.16-1 no .INSTALL
virtualbox-host-modules-4.3.16-2 ok
virtualbox-host-modules-4.3.16-3 ok
virtualbox-host-modules-4.3.18-1 no .INSTALL

Curiously if I rebuild the current community/virtualbox-modules from abs (which is also 4.3.18-1) the .INSTALL file will be placed in the package.
Is there something wrong with the build server(s).

BTW: I'm only talking about x86_64, but I suspect its the same on i686!
Comment by Ole Ernst (olebowle) - Monday, 13 October 2014, 14:04 GMT
Interestingly both packages missing the .INSTALL file were packaged by seblu.
No offense meant, just wanted to point out.
Comment by Sébastien Luttringer (seblu) - Wednesday, 15 October 2014, 21:46 GMT
I see what's wrong. It's linked to a bug in devtools which make somes files unreadable in $startdir and makepkg create package in spite of install file is not readable.
Comment by Doug Newgard (Scimmia) - Thursday, 16 October 2014, 05:32 GMT
Thank you very much for tracking this down, olebowie and seblu. Very vexing issue.
Comment by Sébastien Luttringer (seblu) - Sunday, 14 December 2014, 01:11 GMT
new version of devtools fix the root cause of this. Closing.

Loading...