Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40493 - [frameworkintegration] Qt 5.3 apps segfaults QtCreator, Qt Designer, Qupzilla, SMPlayer...

Attached to Project: Arch Linux
Opened by Rafael Castillo (jrch2k10) - Thursday, 22 May 2014, 16:48 GMT
Last edited by Andrea Scarpino (BaSh) - Tuesday, 27 May 2014, 22:18 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Hi guys,
QtCreator crashes among others apps after Qt-5.3 upgrade, i created an upstream bug report too just in case https://bugreports.qt-project.org/browse/QTBUG-39166.

many tanks for your time

Additional info:
* package version(s)
Qt5-5.3.0-1 to 3
* config and/or log files etc.
attached crashes backtraces

Steps to reproduce:
install or upgrade Qt5 to 5.3 version

My systems
AMD FX 6100 + MSI 970a-g46 MotherBoard
16 GB DDR3 1866 ram
Crucial M500 256GB SSD
AMD Radeon HD 7700 2GB

Drivers: RadeonSI(regular stack / lcarlier repo stack)

Vmware Fusion 6 as guest

Drivers: SVGA gallium driver(regular stack / lcarlier repo stack)
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Tuesday, 27 May 2014, 22:18 GMT
Reason for closing:  Fixed
Additional comments about closing:  frameworkintegration 4.99.0-3
Comment by Andrea Scarpino (BaSh) - Friday, 23 May 2014, 06:55 GMT
I'm happy that I'm not alone in this, anyway Qupzilla works here, while Qt Designer doesn't.

I reported it here: https://bugreports.qt-project.org/browse/QTCREATORBUG-12268
Comment by Sven-Hendrik Haase (Svenstaro) - Friday, 23 May 2014, 15:09 GMT
Dunno, works for me. :/
Comment by Gustavo Alvarez (sl1pkn07) - Friday, 23 May 2014, 19:48 GMT
copy from  FS#40506 

for me break cmplayer, teamspeak3, netctl-gui-qt5... (segment fault)

when open menus and select any option

ts3client_linux[19321]: segfault at 0 ip (null) sp 00007fff0cc8a408 error 14 in ts3client_linux_amd64[400000+bf6000]
netctl-gui[24601]: segfault at 0 ip (null) sp 00007fff589e3868 error 14 in netctl-gui[400000+b0000]
cmplayer[30552]: segfault at 0 ip (null) sp 00007fff0056c428 error 14 in cmplayer[400000+e59000]

greetings
Comment by Sven-Hendrik Haase (Svenstaro) - Friday, 23 May 2014, 20:46 GMT
Works on intel-dri here.
Comment by Сковорода Никита (ChALkeR) - Tuesday, 27 May 2014, 19:15 GMT
For me:
qtcreator — sefault on startup
designer-qt5 — starts fine, but segfaults in «about qt».
qupzilla — starts fine, segfault in «about qt».

Removing kf5 packages fixed this. It's not qt5.3, it's kf5 fault.
Comment by Gustavo Alvarez (sl1pkn07) - Tuesday, 27 May 2014, 19:28 GMT
this make sense, i have installed kf5 packages and gets segfault

the problem is for frameworkintegration. uninstall only this package solve the segfaults
Comment by Rafael Castillo (jrch2k10) - Tuesday, 27 May 2014, 19:30 GMT
confirmed was kf5 packages here too, holy cow batman
Comment by Andrea Scarpino (BaSh) - Tuesday, 27 May 2014, 22:15 GMT
Cannot reproduce with frameworkintegration-git, so this is fixed in next release.

Rebuilding upon Qt 5.3 fixed this.

Loading...