Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40486 - [qtcreator] missing depends on libxkbcommon-x11

Attached to Project: Arch Linux
Opened by Campbell Barton (ideasman42) - Wednesday, 21 May 2014, 15:47 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 21 May 2014, 16:17 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
QtCreator fails to start in XORG with Qt5.3 recent update.

messsage

>>>
This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: eglfs, kms, linuxfb, minimal, minimalegl, offscreen, xcb.
<<<



Additional info:
package version: qtcreator-3.1.1-1


Steps to reproduce:

Run QtCreator, it wont start.

Then install `libxkbcommon-x11`, and it starts fine.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 21 May 2014, 16:17 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#40468 
Comment by Campbell Barton (ideasman42) - Wednesday, 21 May 2014, 15:48 GMT
Note:
I forgot to mention:

I ran:

ldd /lib/qt/plugins/platforms/libqxcb.so

and got a lot of info... but this line was printed.

libxkbcommon-x11.so.0 => not found

Loading...