Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40479 - [chromium] illegal hardware instructions (core dumped) on i686

Attached to Project: Arch Linux
Opened by John (graysky) - Wednesday, 21 May 2014, 10:58 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 21 May 2014, 11:45 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

New version of chromium (35.0.1916.114-1) dies with the following when attempting to launch it on an AMD Athlon XP processor-based system.

% chromium
[1] 1896 illegal hardware instructions (core dumped)

I don't see a core dump file in my homedir which is where I executed the chromium command nor do I see anything in journalctl or dmesg.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 21 May 2014, 11:45 GMT
Reason for closing:  Not a bug
Additional comments about closing:  SSE2 CPU support is required starting from Chromium 35.
Comment by Jens Adam (byte) - Wednesday, 21 May 2014, 11:15 GMT
Working fine here on a Core2Duo (i686 userland on x86_64 kernel... yeah, don't ask).
Comment by Evangelos Foutras (foutrelis) - Wednesday, 21 May 2014, 11:15 GMT
Chromium 35 now requires SSE2 on i686 (we were using the disable_sse2 option before but it's been removed):

https://code.google.com/p/chromium/issues/detail?id=348761#c15
Comment by John (graysky) - Wednesday, 21 May 2014, 11:20 GMT
@Evangelos - Does this mean older i686 hardware cannot use the browser or will you patch i686 to disable that requirement?
Comment by Evangelos Foutras (foutrelis) - Wednesday, 21 May 2014, 11:34 GMT
The former; people with non-SSE2 CPUs will need to switch to Firefox or another browser.
Comment by John (graysky) - Wednesday, 21 May 2014, 11:38 GMT
Fair enough, thanks for the quick reply and for all the work you with package maintenance.

EDIT: I have a package in the AUR that reverts the upstream change and builds with the -Ddisable_sse2=1 flag so it works on older i686 hardware: https://aur.archlinux.org/packages/chromium-no-sse2
EDIT2: Since I am building chromium-no-sse2 for my own use, I have the pre-compiled package available on repo-ck.com for anyone wishing to use it. See https://wiki.archlinux.org/index.php/Repo-ck#Miscellaneous_packages

Loading...