Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40478 - [speech-dispatcher] breaks pydoc3.4 -k xxx

Attached to Project: Arch Linux
Opened by Dima Q (dimaqq) - Wednesday, 21 May 2014, 09:06 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 15 October 2017, 16:53 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

with speech-dispatcher installed:
[dima@bmg /]$ pydoc3.4 -k virtualenv
Usage: pydoc3.4 [options]
A simple dialog based tool for basic configuration of Speech Dispatcher
and problem diagnostics.

pydoc3.4: error: no such option: -k
[dima@bmg /]$


without speech-dispatcher:
[dima@bmg /]$ pydoc3.4 -k virtualenv
virtualenv - Create a "virtual" Python installation
virtualenv_support
[dima@bmg /]$


Some searches return results and then die, some don't return any results.

speechd_config tries to evaluate process comman line using OptionParser regardless on module load. it is a violation of contract.

I'm not sure how to correct it though. I'll report upstream too, but don't keep your hopes up because upstream bug tracker only has issues from year 2012 for Python modules.

Sadly chromium and chromium-dev require speech-dispatcher. I'd gladly live without, but since there is a requirement, and this package breaks much larger functionality, I guess we gotta patch it up.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 15 October 2017, 16:53 GMT
Reason for closing:  Fixed
Comment by Doug Newgard (Scimmia) - Wednesday, 21 May 2014, 15:50 GMT
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Severity (Low → Medium)
  • Task assigned to Felix Yan (felixonmars)
Orphan, assigning to last packager.
Comment by Dima Q (dimaqq) - Thursday, 22 May 2014, 10:12 GMT Comment by mattia (nTia89) - Sunday, 01 October 2017, 15:04 GMT
currently pydoc3.6 seems work

so I think we can close the bug
also because upstream is dated 2014

Loading...