Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40436 - VLC stopped running MJPEG streams

Attached to Project: Arch Linux
Opened by sam (asg1448) - Monday, 19 May 2014, 01:47 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Monday, 19 May 2014, 23:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: attempt to run MJPEG encoded video produces:

main decoder error: no suitable decoder module for fourcc `MJPG'. VLC probably does not support this sound or video format.

I did succeed with the vlc-cache-gen using LD_PRELOAD solution from another bug:

# export LD_PRELOAD=/usr/lib/libgobject-2.0.so.0
# pacman -S vlc


Additional info:
* package version(s): VLC media player 2.1.4 Rincewind (revision 2.1.4-0-g2a072be)
* config and/or log files etc.

warnings produced by running:

$ vlc -vvv
VLC media player 2.1.4 Rincewind (revision 2.1.4-0-g2a072be)
[0xe12fb8] main libvlc debug: VLC media player - 2.1.4 Rincewind
[0xe12fb8] main libvlc debug: Copyright © 1996-2014 the VideoLAN team
[0xe12fb8] main libvlc debug: revision 2.1.4-0-g2a072be
[0xe12fb8] main libvlc debug: configured with ./configure '--prefix=/usr' '--sysconfdir=/etc' '--disable-rpath' '--enable-faad' '--enable-nls' '--enable-lirc' '--enable-ncurses' '--enable-realrtsp' '--enable-aa' '--enable-vcdx' '--enable-upnp' '--enable-opus' '--enable-sftp' 'LUAC=/usr/bin/luac' 'LUA_LIBS=-llua -lm ' 'RCC=/usr/bin/rcc-qt4' 'CFLAGS=-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -I/usr/include/samba-4.0' 'LDFLAGS=-Wl,-O1,--sort-common,--as-needed,-z,relro' 'CPPFLAGS=-D_FORTIFY_SOURCE=2 -I/usr/include/samba-4.0' 'CXXFLAGS=-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4'
[0xe12fb8] main libvlc debug: searching plug-in modules
[0xe12fb8] main libvlc debug: loading plugins cache file /usr/lib/vlc/plugins/plugins.dat
[0xe12fb8] main libvlc debug: recursively browsing `/usr/lib/vlc/plugins'
[0xe12fb8] main libvlc warning: cannot load module `/usr/lib/vlc/plugins/demux/libavformat_plugin.so' (libx265.so.13: cannot open shared object file: No such file or directory)
[0xe12fb8] main libvlc warning: cannot load module `/usr/lib/vlc/plugins/codec/libvdpau_plugin.so' (libx265.so.13: cannot open shared object file: No such file or directory)
[0xe12fb8] main libvlc warning: cannot load module `/usr/lib/vlc/plugins/codec/libvaapi_plugin.so' (libx265.so.13: cannot open shared object file: No such file or directory)
[0xe12fb8] main libvlc warning: cannot load module `/usr/lib/vlc/plugins/codec/libavcodec_plugin.so' (libx265.so.13: cannot open shared object file: No such file or directory)
[0xe12fb8] main libvlc warning: cannot load module `/usr/lib/vlc/plugins/access/libaccess_avio_plugin.so' (libx265.so.13: cannot open shared object file: No such file or directory)
[0xe12fb8] main libvlc debug: saving plugins cache /usr/lib/vlc/plugins/plugins.dat
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Monday, 19 May 2014, 23:11 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Monday, 19 May 2014, 02:52 GMT
Works fine here. Specifically, what package versions of VLC and ffmpeg? And what file?
Comment by sam (asg1448) - Monday, 19 May 2014, 17:07 GMT
i reinstalled ffmpeg, and problem is gone. please close

Loading...