Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40404 - [pypy] fails to build version from mercurial repo

Attached to Project: Community Packages
Opened by Aidan Epstein (aereaux) - Saturday, 17 May 2014, 01:01 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Monday, 19 May 2014, 13:52 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I am trying to translate the latest version of pypy from the mercurial repositories using the arch linux copy of pypy. The arch linux version, fails after a short amount of time with the attached stack trace. The official version from pypy.org (or rather the portable binaries from https://github.com/squeaky-pl/portable-pypy) works without a hiccup.

Additional info:
I'm using version pypy 2.3-1
I'm fairly sure it worked with pypy 2.2.1-1
Attached is the python stack trace that was output.


Steps to reproduce:
pacman -S pypy hg
hg clone https://bitbucket.org/pypy/pypy
cd pypy
pypy rpython/bin/rpython -Ojit pypy/goal/targetpypystandalone.py
wait until it's halfway done with the first fractal.
   log.txt (6.6 KiB)
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Monday, 19 May 2014, 13:52 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed by upstream
Comment by Sven-Hendrik Haase (Svenstaro) - Saturday, 17 May 2014, 07:44 GMT
Not really a packaging problem I think. More likely a problem of our specific changes like gcc 4.9 or split so. Can you post a link to the upstream bug report?
Comment by Aidan Epstein (aereaux) - Saturday, 17 May 2014, 14:45 GMT
I have not reported this issue upstream; I thought it was an arch-specific problem because it works with the portable binaries. Should I have reported it on the pypy bugtracker first? Another thing I have found out is that after translating the version from the mercurial repository with the portable binaries, the resulting executable cannot translate itself, and instead fails with the same error.
Comment by Sven-Hendrik Haase (Svenstaro) - Saturday, 17 May 2014, 14:50 GMT
In that case it's most probably a gcc 4.9 issue. Just report it upstream, they'll fix it quickly. Pretty sure it has nothing to do with arch, it just so happens that we have gcc 4.9.
Comment by Aidan Epstein (aereaux) - Saturday, 17 May 2014, 15:20 GMT
OK, thanks for the help.

Loading...