Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40401 - [feh] feh-cam and gen-cam-menu no longer built by default

Attached to Project: Arch Linux
Opened by Wilhelm Schuster (wlhlm) - Friday, 16 May 2014, 22:02 GMT
Last edited by Gaetan Bisson (vesath) - Saturday, 17 May 2014, 08:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
With version 2.12 of `feh`, the tools `feh-cam` and `gen-cam-menu` are no longer built by default. From the changelog:
`
> feh-cam and gen-cam-menu are no longer installed by default. Use `make install cam=1` to install them or make uninstall cam=1 && make install cam=0 to remove them permanently

The PKGBUILD has not been adjusted: either the `perl` optional dependency has to be removed, or `cam=1` added to the build options.

Additional info:
* package version: feh-2.12
Attached file:
* updated PKGBUILD with `cam=1` added
   PKGBUILD (0.9 KiB)
This task depends upon

Closed by  Gaetan Bisson (vesath)
Saturday, 17 May 2014, 08:10 GMT
Reason for closing:  Fixed
Additional comments about closing:  in SVN
Comment by Wilhelm Schuster (wlhlm) - Friday, 16 May 2014, 22:03 GMT
Forgot to update the `pkgrel` variable.
   PKGBUILD (0.9 KiB)
Comment by Gaetan Bisson (vesath) - Saturday, 17 May 2014, 03:55 GMT
Reason is that feh-cam and gen-cam-menu have been deprecated for over two years; see /usr/share/doc/feh/ChangeLog:

Mon, 05 Sep 2011 10:56:58 +0200 Daniel Friesel <derf@finalrewind.org>
* Release v1.16
* The feh-cam and gen-cam-menu tools are deprecated as well
(but will remain in this distribution for at least 1 year)

I do not feel very good re-enabling something upstream has deprecated. Could you explain why these are really needed? Or argue with upstream that they shouldn't be deprecated?
Comment by Wilhelm Schuster (wlhlm) - Saturday, 17 May 2014, 06:42 GMT
I didn't know that these tools were depreacated. But I also would like to remove these from the package. I just wanted to take over some work and supply a fixed PKGBUILD. I thought that maybe someone needs these tools.

I have attached a PKGBUILD with the other solution (removing the perl optdepends).
   PKGBUILD (0.9 KiB)
Comment by Gaetan Bisson (vesath) - Saturday, 17 May 2014, 08:09 GMT
Thanks!

However I did not elect to bump the pkgrel: upstream releases often enough that this will end up in our packages soon, and in the meantime it's a harmless optdepends.

Loading...