Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40378 - [cinnamon-control-center] Power module crashes, still not fully compatible with upower 0.99

Attached to Project: Community Packages
Opened by sb56637 (sb56637) - Thursday, 15 May 2014, 15:48 GMT
Last edited by Balló György (City-busz) - Thursday, 15 May 2014, 20:35 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Balló György (City-busz)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Hello,

The "Power" settings in the Cinnamon Control Center still crashes due to an incompatibility with the new upower 0.99 API. This is the error:

----------
$ cinnamon-settings power
Python module

Loading Power module
/usr/bin/python2: symbol lookup error: /usr/lib/cinnamon-control-center-1/panels/libpower.so: undefined symbol: up_client_get_can_hibernate
----------

For some reason, it appears that users that are running this applet...
power@airlog.pisz.pl"> https://github.com/robin92/cinnamon-power-applet/tree/master/power@airlog.pisz.pl
...are not seeing this bug. But users running the standard power@cinnamon.org applet and users with no power applet at all can't use the Power settings due to this bug.
This task depends upon

Closed by  Balló György (City-busz)
Thursday, 15 May 2014, 20:35 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#40193 
Comment by sb56637 (sb56637) - Thursday, 15 May 2014, 20:22 GMT
  • Field changed: Percent Complete (100% → 0%)
Please re-open, because  FS#40193  is for a specific patch, marked as IMPLEMENTED, but more work besides that patch is needed to fix the Cinnamon Control Center.
Comment by Balló György (City-busz) - Thursday, 15 May 2014, 20:24 GMT
It's an upstream task, but I'll check this problem. Anyway, Cinnamon's upower support is still broken, because cinnamon-settings-daemon is still not ported to upower-1 yet, and it's not an easy task.
Comment by Doug Newgard (Scimmia) - Thursday, 15 May 2014, 20:33 GMT
And now we have two bugs open for the same thing.
Comment by Balló György (City-busz) - Thursday, 15 May 2014, 20:35 GMT
Okay, I'm closing this one, please do not request to reopen it. Follow this:
https://bugs.archlinux.org/task/40193

Loading...