Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40354 - [python] missing libpython3.4m.a

Attached to Project: Arch Linux
Opened by Laurent Artaud (laurenta) - Wednesday, 14 May 2014, 10:04 GMT
Last edited by Felix Yan (felixonmars) - Saturday, 17 May 2014, 03:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
"libpython3.4m.a" is not part of the package, although it is built by the makepkg.

$ sudo pacman -Ql python | grep -i libpython
python /usr/lib/libpython3.4m.so
python /usr/lib/libpython3.4m.so.1.0
python /usr/lib/libpython3.so
python /usr/lib/python3.4/config-3.4m/libpython3.4m.so

Additional info:
* package version(s)
python-3.4.0-3-x86_64
This task depends upon

Closed by  Felix Yan (felixonmars)
Saturday, 17 May 2014, 03:02 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Wednesday, 14 May 2014, 10:09 GMT
This is intentional, as static libs are stripped. Is there any valid reason other than "I don't want my software to depend on python" why you need the static libs?
Comment by Laurent Artaud (laurenta) - Wednesday, 14 May 2014, 11:48 GMT
I was attempting to compile the static version of luxrender using the official (luxrender.net) compilation tools and was asked for it…
As I saw it was built, I thought there was a mistake in the PKGBUILD…
Comment by Felix Yan (felixonmars) - Wednesday, 14 May 2014, 13:54 GMT
It was intentional: https://mailman.archlinux.org/pipermail/arch-dev-public/2013-March/024552.html

If you really need static libs, please adjust PKGBUILD options to keep staticlibs, and build it yourself.

Loading...