Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40352 - [libmariadbclient] package includes static libraries

Attached to Project: Arch Linux
Opened by Christian Hesse (eworm) - Wednesday, 14 May 2014, 08:20 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Wednesday, 14 May 2014, 11:32 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
package includes static libraries:

# pacman -Qlq libmariadbclient | grep .a$
/usr/lib/libmysqlclient.a
/usr/lib/libmysqlclient_r.a
/usr/lib/libmysqld.a
/usr/lib/libmysqlservices.a

Additional info:
libmariadbclient 10.0.11-1
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Wednesday, 14 May 2014, 11:32 GMT
Reason for closing:  Not a bug
Comment by Evangelos Foutras (foutrelis) - Wednesday, 14 May 2014, 08:51 GMT Comment by Christian Hesse (eworm) - Wednesday, 14 May 2014, 08:58 GMT
You are right, looks like this is intentional. Are there any good reasons? Could not find information other than "keep static libraries in libmariadbclient" in svn commit message.
Comment by Bartłomiej Piotrowski (Barthalion) - Wednesday, 14 May 2014, 09:05 GMT
I don't remember actually. I haven't found anything on the bug tracker, so probably an user requested it via e-mail.
Comment by Bartłomiej Piotrowski (Barthalion) - Wednesday, 14 May 2014, 11:32 GMT
Ok, found it. Alexander Rodseth (xyproto) asked me to include them, because neko (AUR) fails to build otherwise.

Loading...